English
Ask Your Question
1

LibreOffice 3.5 spellcheck not working

asked 2012-02-19 11:17:19 +0200

hotaru gravatar image

updated 2013-03-26 15:32:17 +0200

manj_k gravatar image

Hi, I have Windows 7 (64 bit). Spellcheck in 3.4 was working fine. I unistalled this version and installed the new 3.5 and spellcheck stopped working. I went through this troubleshooting tutorial: http://user.services.openoffice.org/en/forum/viewtopic.php?f=74&t=16512 but it didn't help - I don't have the blue check mark in the general settings panel by my language (polish). How can I fix this?

edit retag flag offensive close merge delete

9 answers

Sort by » oldest newest most voted
1

answered 2012-02-19 11:38:48 +0200

Pedro gravatar image

updated 2012-06-03 16:10:38 +0200

I suggest that you manually uninstall the Polish dictionaries (if they are installed) and then download and install it from
http://libreoffice-na.us/English-3.5-installs/dictionary.html

You need to Exit and restart LibreOffice for the dictionary changes to become effective.

edit flag offensive delete link more

Comments

For newer versions of LO, the link has to be updated thus: http://libreoffice-na.us/English-3.6-installs/dictionary.html and http://libreoffice-na.us/English-4.0-installs/dictionary.html

carnendil ( 2013-06-03 18:38:37 +0200 )edit
2

answered 2012-06-03 13:28:02 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Because link posted by Pedro is dead i'm posting my solution: Go to Program Files (x86)\LibreOffice 3.5\share\extensions move all dict-xx folders except dict-en somewhere else and restart LibreOffice - it should unload extensions. After this operation exit LibreOffice and move back all dict-xx folders to extensions folder and open LibreOffice. LibreOffice will load extensions and all languages spell checking should work.

edit flag offensive delete link more

Comments

Link updated. Nice solution BTW ;)

Pedro ( 2012-06-03 16:11:45 +0200 )edit
1

answered 2012-06-13 09:11:49 +0200

hjp gravatar image

I deleted the profile directory and restarted LibreOffice. It created a new profile directory and then the spell check is working.

edit flag offensive delete link more

Comments

This worked for me as-well, thanks.

jaybiz3 ( 2012-08-21 01:43:50 +0200 )edit
0

answered 2012-09-04 20:52:09 +0200

I was having a spell check problem also. as it happened the program did not know what language the text was. once i set all text to English it started working. I was pasting from a notepad so I can use the voice recognition, Libreoffice does not work with it :-(

edit flag offensive delete link more
0

answered 2013-01-20 09:34:02 +0200

Using Linux openSUSE 12.2 LO3.5 I also was having problems with spell checker not identifying incorrectly spelt words as there were typed. having read the notes above, I then noticed that in Tools, Options, select Language settings, Languages window, under the 'Default language for documents' the English (USA) drop down option had an ABC above a tick icon which the English (UK) did not have. Thinking this ment that the English (UK) language dictionary was not installed. A quick look at 'Installing Extensions in LibreOffice.pdf' [http://extensions.libreoffice.org/] helped me add the english (UK) language. Goto to Tools, Extension Manager, select the Get more extensions online... option at the bottom of the window and pick the language you need from the extensions tab on the web page the link brings up. Hope this helps.

edit flag offensive delete link more
0

answered 2012-06-03 14:16:32 +0200

manj_k gravatar image

[With regard to LibreOffice 3.5.4]

Please see also:

Bug 50552 - SPELL check does not mark wrong text and capitalization rules.

→ (Workaround) http://ask.libreoffice.org/question/2878/any-known-issues-exporting-to-mediawiki-with?answer=3035#answer-container-3035

edit flag offensive delete link more
0

answered 2013-05-16 07:36:54 +0200

Running Linux mint. I have really tried everything to make Libre office spell Australian or spell at all except installing new version 4. I cannot waste any more time so I have replaced it with Openoffice.

edit flag offensive delete link more

Comments

The v3.5 series is EOLed now but even so it sounds like you have a Mint-specific problem. I have no problem with Australian spelling here under Ubuntu for either v3.5.7.2 or v4.0.2.2. Were you running the repository version or the version downloadable from the website?

oweng ( 2013-05-16 08:02:26 +0200 )edit

Try installing hunspell (and a hunspell dictionary package eg. hunspell-en). After doing that and deleting .libreoffice, spell check started working for me. Make sure u delete the profile after closing all running libreoffice instance.

Refer https://wiki.archlinux.org/index.php/LibreOffice#Spell_checking Spell check was not working for me on Libreoffice 4. But after this it started working.

Ayush Goyal ( 2013-08-24 21:19:04 +0200 )edit
0

answered 2012-09-19 03:52:58 +0200

dpell gravatar image

Windows 7, 64 bit. LibreOffice 3.6.0.4 (Build ID: 932b512) Spell check worked fine on my older machine. However on the Windows7 PC, even though the AutoSpellcheck button was clicked on, incorrectly spelled words were not underlined. Also, when Spelling and Grammar Check (F7) was manually run, it would erroneously report that all was correct. I deleted the extra dictionaries not needed (all but english in the directory mentioned above) to no avail.

Going to Tools>Language>"For Selection" was set to English. However, going to Tools>Language>"For all Text": nothing was set(same with Tools>Language>"For Paragraph").

**Only when I set 'For all Text' to English did the spell checking work properly. [At one point, I also had set both "For Paragraph" & "For all Text" to "Reset to Default Language"]. It seems strange that setting the default language did not carry over to the other settings by default -- 'For Paragraph', etc).

Hope that helps anyone having similar problems.

edit flag offensive delete link more
0

answered 2013-06-03 17:46:01 +0200

danteuk gravatar image

updated 2013-06-03 17:51:19 +0200

Same problem, but Kubuntu LibreOffice 3.5 UK English. Text marked as UK English, but spell checking fails to find anything. ( the spell checking dialog window doesn't even have a language set in the combobox at the top, even though I've the text language and pull down menus show the language is set correctly. ) Really frustrating that such a basic feature doesn't work at all.

PS: deleting my .libreoffice didn't make difference.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2012-02-19 11:17:19 +0200

Seen: 23,783 times

Last updated: Jun 03 '13