English
Ask Your Question
0

Spell checking not working in v3.4.2 [closed]

asked 2012-04-03 17:24:01 +0200

mickelsen gravatar image

updated 2013-11-11 21:46:54 +0200

manj_k gravatar image

I have LibreOffice ver. 3.4.2 and the spell checker does NOT work. Apparently this has been a problem for many users. What do I have to do to get a working spell checker? Do I have to fall back to ver. 3.3.3? Please help. Thanks, Mark

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Closed for the following reason "the question is answered, right answer was accepted" by manj_k
close date 2013-11-11 21:53:33.782955

8 answers

Sort by » oldest newest most voted
0

answered 2012-04-03 18:20:31 +0200

manj_k gravatar image

Probably related to → Bug 37195 - Dictionary access lost after LibO upgrade – Status: CLOSED FIXED (LibreOffice 3.4.4)

Solutions

(1) Workaround

  1. Close LibO (+ Quickstarter, if enabled).
  2. Go to your user profile: rename the folder bundled [path: ...\3\user\extensions\bundled], e.g.: to bundled_old, or remove this folder.
  3. Restart LibO: A new folder bundled will be created in the user profile. All bundled dictionaries will be available.

(2) Best solution

Install a current version → LibreOffice 3.5.1 / LibreOffice 3.4.6

edit flag offensive delete link more

Comments

1

This solution worked for me. The file is in the AppData\Roaming folder in your main user profile in Windows.

JimJamJames ( 2012-12-18 20:34:06 +0200 )edit
1

answered 2012-07-01 23:21:27 +0200

profquatermass gravatar image

updated 2012-07-01 23:22:06 +0200

This happened to me recently in Version 3.5.2 Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18 in Windows 7 Pro.

Renaming the folder 'bundled' worked. By why did I have to do this if it's supposingly fixed in v3.4.4?

edit flag offensive delete link more

Comments

1

answered 2012-06-22 21:26:11 +0200

Lewis Cowles gravatar image

Well it's lovely going through all this but in debian, ubuntu and mint if the above does not work try this

sudo apt-get install myspell-en-gb

It worked for me after hours of being very very irritated. Funny thing is Chrome's spell checking worked. Also as an N.B replace -en-gb with your language i.e. -es (spanish) -fr (french) en-us (american take on the english language)

edit flag offensive delete link more
0

answered 2013-03-21 13:49:00 +0200

Will gravatar image

sudo apt-get install myspell-en-au

Worked for me too. Initially I had installed Mint 14 without downloading languages. Installed package via Synaptic. Thanks for the solution.

edit flag offensive delete link more
0

answered 2012-12-17 16:45:03 +0200

If you are reading this in a forum post it will not be spell checked the same way that your LibreOffice or OpenOffice would do it on your PC. To view it that way download it from: this Google link to your PC and open it from there. You will get the gist of what I mean by reading this post, but you will not see what I mean unless you download the file (or create your own file in your office suite).

Below are two blocks of text that have different language formatting.


one

twoz: twoz does not get spell checked because its language is [none]

three


one

twoz: twoz gets spell checked (and fails) because its language is [English (USA)]

three


To see the language that is being used: highlight a block of text and go to the menu: Format → Character.
There are hidden language settings for blocks of text, the whole current file and new files created from scratch.

When you are working on a file: Changing language settings from within a file through the menu system like so: Tools→Options, then “Language Settings” will only change the setting for the document that you are working on (or that you newly create from within the editor).

To change the language settings for all future newly created files you must use the same method (Tools→Options, then “Language Settings”), but do it from the configuration program LibreOffice (soffice.exe). Note; that the program will refuse to run (without giving any explanation or warning message) until you close all instances of any of the office suite programs.

Another way to “fix” a file with problematic language settings is through the menu:

Tools→Language→For Selection

Or Tools→Language→For Paragraph

Or Tools→Language→For all Text

There is no way to “fix” all effected files on your system. Unless somebody has written a program that I don't know about.

Happy holidays to all.

edit flag offensive delete link more
0

answered 2012-11-24 22:53:21 +0200

Linux only changed sudo apt-get install myspell-en-gb to sudo apt-get install myspell-en-au

worked well for me. I replaced -gb with -au for australia and it downloaded language. I shut down LO and restarted it. All worked ok. The reason I think. My locality is set to Australia. Australia language is not downloaded on to cd install image by default. Also, I found changing my locality to GB or USA in Tools/Options/Language Settings/Languages also worked. I had to change currency to USA as Australia uses dollars not pounds. Changing the language to usa or gb should work for windows too but I can't confirm that. Gave up on Bill and windows after he made too many changes to new versions of windows for no apparent reason. I suppose Bill had to change the operating system to sell more books to teach us what we already knew.

edit flag offensive delete link more
0

answered 2012-08-04 11:31:41 +0200

idiota gravatar image

Deleting the Bundled folder didn't work. Reinstalling didn't work.

I found that I had my LibreOffice Writer default language set to English (New Zealand). There is no dictionary for my locality of English.

The problem is fixed by clicking Tools/Options/Language Settings/Languages

It allows dozens of flavours of English, BUT spelling is disabled for all the ones that don't have the little blue tick ABC icon beside them. Looks like we can LABEL text any of hundreds of languages, but only a few of them have dictionaries installed.


Hanlon's razor: "Never attribute to malice that which can be adequately explained by stupidity." Alternatively, "Do not invoke conspiracy as explanation when ignorance and incompetence will suffice, as conspiracy implies intelligence."

edit flag offensive delete link more

Comments

1

Missing spell check support en-NZ has been fixed in LibreOffice 3.6.x,

see → Why is English (New Zealand) not New Zealand English

manj_k ( 2012-08-04 11:56:52 +0200 )edit
0

answered 2012-08-21 00:08:34 +0200

pol098 gravatar image

Using LibreOffice Win7/32 recently updated to 3.6 I had the same problem. Ticking dictionaries made no difference. Using the latest LibreOffice made no difference. Deleting the "bundled" directory (actually moved to temporary storage) worked. There were a great many differences between the old and the re-created directory (but I didn't check them in detail).

edit flag offensive delete link more

Stats

Asked: 2012-04-03 17:24:01 +0200

Seen: 18,983 times

Last updated: Mar 21 '13