English
Ask Your Question
1

LibreOffice Impress messes up letter spacing in Slide Show, design view looks normal

asked 2012-05-16 20:38:01 +0200

0xC0000022L gravatar image

updated 2013-03-26 14:35:20 +0200

manj_k gravatar image

I already asked that exact question over at Superuser.com and was referred here in a comment. The question is reproduced below the horizontal rule.

The document in question can be downloaded from here.


On Windows, using LibreOffice 3.5.1.2, when I create a presentation using Impress, the Slide Show (F5) cuts off the bottom and top (similar to wide-screen movies) and thus changes the aspect ratio, messing up the fonts. What gets messed up in particular is the spacing between letters, which gets stretched a lot.

Here's how it looks during creation:

Design-time view

Here's how it looks on the screen with the preview (fine, too):

enter image description here

And now the messed up presentation as it appears on my screen (which has the same aspect ratio as our projector, 4:3):

enter image description here

I also noticed that the framing with the background you choose during initial creation of the presentation is not even shown on the last view.

How can I make sure that the aspect ratio (and consequently the inter-letter spacing and so on) remains the same, no matter what?

edit retag flag offensive close merge delete

Comments

It would help in trying to reproduce and track the problem if you could upload that test presentation.

luyu ( 2012-05-16 20:58:16 +0200 )edit

An attempt to upload an attachment results in SyntaxError: at index 5 in "data = ": expected expression, got <end of file>

0xC0000022L ( 2012-05-16 21:40:26 +0200 )edit

Tested the uploaded file under GNU/Linux with LibreOffice 3.5.3 and it works fine. Try installing latest LO version as @manj_k advised.

luyu ( 2012-05-16 22:26:33 +0200 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2012-05-16 21:45:25 +0200

manj_k gravatar image

updated 2012-05-16 22:50:59 +0200

Pretty sure → Bug 46901 - SLIDESHOW shows characters too slim with Hardware Acceleration activated - cairo canvas used in error on windows.

Please try with the current version LibreOffice 3.5.3.

Workaround for v3.5.1:

Disable hardware acceleration via

Tools → Options → LibreOffice → View → Graphic output

Addendum: Screenshot (LibreOffice 3.5.3)

Slide Show: Untitled1.odp image description

edit flag offensive delete link more

Comments

Thanks, will try that. Of course disabling hardware acceleration isn't really an option, because this machine is used for way more thing. Probably means I'll have to ban LO into a VM in order to create and test my stuff there ... :-| ... and btw, I can't even upvote your answer, this is ridiculous.

0xC0000022L ( 2012-05-18 15:39:50 +0200 )edit

Please read the bug report, fdo#46901 (regression) has been fixed in LO 3.5.2.2. Hardware acceleration has not been disabled in the screenshot above.

manj_k ( 2012-05-18 16:25:19 +0200 )edit
1

@manj_k: I realized that when reading through the bug report, thanks. I now installed it and it works. But I still cannot upvote your answer, not even a comment. I'll see whether I can accept it, though.

0xC0000022L ( 2012-05-18 17:00:14 +0200 )edit
Login/Signup to Answer

Stats

Asked: 2012-05-16 20:38:01 +0200

Seen: 1,161 times

Last updated: May 16 '12