Frage stellen
0

Datenquellenfeld löscht sich von selbst

gefragt 2017-10-27 07:53:08 +0200

Dieser Post ist als Wiki-Post markiert

Das ist ein Wiki-Beitrag. Jeder mit Karma >75 darf diesen Beitrag verbessern.

Hallo, ich erstelle pdf-Formulare über Calc. Über die Formular-Steuerelement füge ich Dropdownlisten ein. Jedoch wenn ich die Datei speichere und schliesse verliert sie immer den Link mit der Datenquelle (das Feld ist immer leer).

Ebenfalls werden diese Felder immer auf "nicht aufklappbar" umgestellt.

Das ist sehr umständlich da bei jedem Öffnen in Calc alles Droppdownfelder neu eingestellt werden müssen.

Hat jemand eine Idee woran das liegen könnte ?

Vielen Dank im Voraus

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Habe ich das richtig verstanden: Du versuchst, *.pdf-Formulare zu erstellen und hast gleichzeitig einen Link zu einer Datenquelle? PDF-Formulare kannst Du nicht mit einer *.odb-Datenquelle verbinden. Deine Listenfelder müssen schon entsprechende Listeneinträge vorweisen. Wertelisten aus dem Reiter "Daten" werden vermutlich nicht berücksichtigt.

Gruß

Robert

RobertG Gravatar-BildRobertG ( 2017-10-27 11:42:53 +0200 )Bearbeiten

das problem ist nicht der pdf, da funktionniert die Dropdown funktion. Es ist nut die ods Datei die nach speichern, schliessen und wieder öffnen den link verliert

Lungo1971 Gravatar-BildLungo1971 ( 2017-10-27 17:06:07 +0200 )Bearbeiten

2 Antworten

0

geantwortet 2017-10-27 08:48:46 +0200

Toxitom Gravatar-Bild

In welchem Format speicherst Du denn die Calc-Datei? Im nativen *.ods (OpenDocument) Format? Oder verwendest Du ein Fremdformat (z.B. Excel) - dann wird genau so ein Phänomen auftreten.

VG Tom

Bearbeiten Melden löschen Link mehr

Kommentare

Ich speichere im ods Format. Und beim wiederöffnen muss ich die Dropdownfelder wieder neu einstellen und die Datenbank auswählen.

Lungo1971 Gravatar-BildLungo1971 ( 2017-10-27 17:05:14 +0200 )Bearbeiten
0

geantwortet 2017-10-29 17:46:43 +0200

RobertG Gravatar-Bild

Ich habe das jetzt einmal mit der Version: 5.4.1.2.0+, Build-ID: 40m0(Build:2) von OpenSUSE getestet. In der Tat ist es so, dass weder LO-Calc noch LO-Writer den Datenquelleneintrag aus der eigenen Datei auslesen können. Hier liegt wohl ein Bug vor.

Melde doch einmal kurz, welche Version unter welchem System Du nutzt.

Wenn Du die Datenquelle in LO anmeldest, dann erscheinen anschließend auch die Daten, wenn das Formular erneut geöffnet wird.

Gruß

Robert

Bearbeiten Melden löschen Link mehr

Kommentare

Hallo, ich benutzte die Version 5.4.2.2 von calc auf Windows 7 Pro Gruss

Lungo1971 Gravatar-BildLungo1971 ( 2017-10-30 07:32:53 +0200 )Bearbeiten

Ist dieser Bug: Bug 109004

Hatte ganz vergessen, dass ich da schon etwas zu geschrieben hatte. Nur der Titel war vorher so merkwürdig, dass ich das Ding nicht finden konnte.

Gruß

Robert

RobertG Gravatar-BildRobertG ( 2017-11-01 18:06:12 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2017-10-27 07:53:08 +0200

Angesehen: 55 Mal

Aktualisiert: Oct 29 '17