sverweis nachkommastellen formatieren

gefragt 2019-08-27 12:32:19 +0100

metastadt Gravatar-Bild

Halli hallo liebes Forum,

ich habe eine sverweis Frage die mich wahnsinnig macht und ich hoffe bei Euch auf eine Antwort. Es geht um eine sehr simple Rechnungstabelle: Ich habe eine Tabelle ("Übersicht") angelegt wo ich meine Rechnungsbeträge eintrage, nun möchte ich per sverweis diese Beträge automatisch bei Eingabe der Rechnungsnummer in die Tabelle Druckansicht kopieren. Das klappt auch alles prima, aber sverweis nimmt die Nachkommastellen nicht mit hinüber, bedeutet. 100,00 in Tabelle "Übersicht" wird zu 100 in Tabelle "Druckansicht". Warum? Ich habe schon alle möglichen Formatierungen vorgenommen, aber es verändert sich nichts. Was mache ich falsch?

Ich danke Euch für eine Antwort. Herzliche Grüße

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Da hast Du recht - keine Formel nimmt irgendeine Formatierung irgenwohin "mit", da ja gar nichts kopiert wird, sondern auf etwas verwiesen wird. Und verwiesen wird auf den Wert einer Zelle. Daher musst Du die Zelle, in der das =SVERWEIS(...) steht, Deinen Bedürnissen entsprechend formatieren.

Und ganz nebenbei: Ein Format hat nichts mit dem wirklich in LibreOffice gespeicherten Wert zu tun. Das Format dient lediglich der Darstellung dieses Wertes.

Opaque Gravatar-BildOpaque ( 2019-08-27 13:03:28 +0100 )Bearbeiten

Alles klar, danke schon mal für Deine Antwort. Und wie mache ich das konkret? Ich habe es beispielsweise mit WERT probiert. Das sah dann so aus: =WERT(SVERWEIS(C10;$Übersicht.A2:U90;8;0)&""), aber dort wurde mir dann nur eine Nachkommastelle ausgegeben. Gibt es noch andere Möglichkeiten?

metastadt Gravatar-Bildmetastadt ( 2019-08-27 13:08:27 +0100 )Bearbeiten

Wie formatierst Du normal eine Zelle? Rechter Mausklick -> Zelle formatieren und Dein gewünschtes Format eingeben. Sonst nix - Wozu das =WERT()?, einfach =SVERWEIS(C10;$Übersicht.A2:U90;8;0) und die Zelle formatieren (Voraussgesetzt natürlich dass in der Tabelle $Übersicht auch wirklich Werte vom Typ "Dezimazahl" oder "Integer" stehen).

Opaque Gravatar-BildOpaque ( 2019-08-27 13:15:46 +0100 )Bearbeiten

Vielen Dank für Deine Antwort, das hat zunächst bei mir nicht geklappt. Aus welchem Grund auch immer. Ich bin dann aber bei einem anderen Forum fündig geworden, mit folgendem Tipp, der bei mir den Durchbruch gebracht hat: Vermutlich wurden die Werte aus der Datenbank im Textformat übernommen; ein häufiges Problem bei der Übernahem externer Daten wenn dies mittels Copy/Paste geschieht.

Schaffe wie folgt Abhilfe:

  • Spalte markieren
  • Format 'Standard' oder 'Zahl' vergeben (auch wenn das schon so sein sollte)
  • Spalte weiterhin markiert lassen
  • Menü: 'Daten'
  • Text in Spalten
  • Fertig stellen

Das hat bei mir dann auch funktioniert. Ich danke Dir für Deine Hilfe! Einen schönen Tag noch!

metastadt Gravatar-Bildmetastadt ( 2019-08-27 13:46:26 +0100 )Bearbeiten

Davon, dass die Werte aus einer Datenbank kommen und Text sind, hast Du leider kein Wort erzählt ind ich habe ganz bewusst in meinem Kommentar auch geschrieben (Voraussgesetzt natürlich dass in der Tabelle $Übersicht auch wirklich Werte vom Typ "Dezimazahl" oder "Integer" stehen).

Opaque Gravatar-BildOpaque ( 2019-08-27 13:49:45 +0100 )Bearbeiten