Frage stellen
0

in meiner Formel =WENN(C3="X";1;0) wird bei librecalc klein-x und groß-X unterschieden

gefragt 2019-11-13 18:38:35 +0100

Fred17 Gravatar-Bild

=WENN(C3="X";1;0) Abfrage der Zelle C3 Ergebnis in D3 = 1 oder ggf. 0

Wie kann ich die Formel adaptieren, dass sowohl bei der Eingabe eines kleinen x, als auch bei der Eingabe eines großen X die Formel unter Calc funktioniert.

Bisher hatte ich nur MS Excel und dort funktioniert die Formel mit kleinem oder großen x. Calc unterscheidet und verlangt die exakte Eingabe.

Könnte ich die Formel ggf. erweitern für x und X ?

Bearbeiten Tags ändern Melden schließen vereinen löschen

3 Antworten

0

geantwortet 2019-11-13 18:50:14 +0100

RobertG Gravatar-Bild

Schreibe einfach

=WENN(GROSS(C3)="X";1;0)

Die Unterscheidung zwischen Groß- und Kleinschreibung halte ich auch an dieser Stelle für völlig korrekt.

Bearbeiten Melden löschen Link mehr

Kommentare

Vielen Dank, es funktioniert!!!!!!!!!!!

Fred17 Gravatar-BildFred17 ( 2019-11-13 19:35:16 +0100 )Bearbeiten
2

geantwortet 2019-11-14 09:51:40 +0100

PKG Gravatar-Bild

Hallo, man kann auch einstellen, ob zwischen Groß- und Kleinschreibung unterschieden werden soll.

Menü: Extras – Optionen – LO Calc – Berechnen – Allgemeine Berechnungen – [x]Groß-⁠ und⁠ Kleinschreibung

Bearbeiten Melden löschen Link mehr
0

geantwortet 2019-11-13 18:49:19 +0100

Opaque Gravatar-Bild

updated 2019-11-13 19:06:27 +0100

Hello

=IF(UPPER(C3)="X";1;0) - ich benutze nur englische Funktionsnamen.
Auf Deutsch: =WENN(GROSS(C3)="X";1;0)

Ich hoffe das hilft.

Wenn die Antwort deine Frage beantwortet, oder geholfen hat, Dein Problem zu lösen, dann klick bitte das kleine Häkchen (✔) direkt neben der Antwort (wird grün dabei).

Bearbeiten Melden löschen Link mehr

Kommentare

Vielen Dank, es funktioniert!!!!!!!!!!!

Fred17 Gravatar-BildFred17 ( 2019-11-13 19:35:05 +0100 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2019-11-13 18:38:35 +0100

Angesehen: 50 Mal

Aktualisiert: Nov 14