Frage stellen
1

export als PDF: Fehler beim Speichern des Dokumentes

gefragt 2019-12-04 10:05:21 +0100

dewege Gravatar-Bild

updated 2019-12-04 10:18:37 +0100

ebot Gravatar-Bild

Hallo Libreoffice Experten

Ich nutze LO auf MacOS Mojave (werde noch lange nicht auf Catalina wechseln) nutze Netzwerklaufwerke via SMB/CIFS von Synology DS218+ Ich war bisher auf LO 5.x und arbeite mit folgendem Workflow: LO-Calc Dokument schreiben und auf Netzwerk speichern, gleich danach PDF exportieren und ebenfalls auf Netzwerk speichern (zB direkt via PDF-Icon in der Toolbar). Nach dem Speichern öffnet sich automatisch das PDF (in meinem Fall mit Apple Preview-App)

Neu mit LO 6.2.8.2 (gestern Update gemacht):

  • Calc-Dok speichern auf Netzordner (TestCalc.ods) klappt,
  • PDF erzeugen im selben Netzordner (test.pdf) --> Fehlermeldung "Fehler beim Speichern des Dokumentes TestCalc: Allgemeiner Fehler. Allgemeiner Ein/Ausgabefehler."

Auch mit LO Writer geschieht dasselbe. Auch via Dateimenu Als PDF exportieren geschieht derselbe Fehler. Das PDF öffnet sich nicht mehr automatisch. Das PDF ist danach in dem Ordner vorhanden und lässt sich öffnen. Eigenartigerweise bezieht sich die Fehlermeldung auf den Namen des Calc-Dokuments und nicht auf den Namen des PDFs.

Wenn ich das PDF auf einem lokalen Ordner (zB Desktop) speichere (Calc-Dokument immer noch auf dem Netz), kommt keine Fehlermeldung und das PDF öffnet automatisch wie erwartet.

Virenscanner (GDATA) hab ich testhalber deaktiviert. Der Fehler kommt trotzdem. Der Virenscanner war auch mit der vorherigen LO Version aktiv - ohne Probleme. Noch etwas davor nutzte ich ein Western Digital MyBookLife NAS ebenfalls via smb/cifs, wo der PDF-Export ebenfalls funktionierte. Auch dort tritt heute mit LO 6 der Fehler auf.

Hat jemand einen Lösungsvorschlag oder Vermutung zur Ursache des Problems?. Ich gebe gerne weitere Infos wenn nötig.

Schon mal Danke dewege

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Hallo - zuerst mal vielen Dank für die klare Aufbereitung der Frage (sowas ist leider selten hier).

Zum Thema:
Also es scheint beim Übergang von LibreOffice V5.x nach LibreOffice V6.x eine Änderung bzgl. der Lockfiles gegeben zu haben. Fehler beim Erzeugen der Lockfiles wurden in v5.x und vorher wohl gnädig ignoriert und poppen nun in V6.x hoch. Ich schlage mal folgenden Test vor (daher dies auch noch nicht als Antwort, da ich den Ausgang des Tests erst abwarten will):

  • Öffne ein Terminal in Mojave
  • cd in den Pfad Deines SMB/CIFS mounts
  • Versuche eine Datei namens .~lock.TestLockFile.odt# anzulegen (Kommando: touch .~lock.TestLockFile.odt#)

Meine Hoffnung wäre, dass das nicht geht, denn dann wäre das Problem gefunden.

Bitte schreib Dein Feedback hier als kommentieren und nicht als Antwort.

Opaque Gravatar-BildOpaque ( 2019-12-04 10:54:27 +0100 )Bearbeiten

Danke für Deine Blumen Opaque, bin selbst Informatiker und mache Troubleshooting. (Kenne daher Beschreibungen wie "der Bildschirm zeigt NICHTS mehr" obwohl nur das gewünschte Fenster nicht mehr da ist.) Konnte ich grade schnell probieren, muss Dich aber leider enttäuschen, denn das funktioniert: -rwx------ 1 ith2 staff 0 4 Dez 11:10 .~lock.TestLockFile.odt# Ich sehe dort auch ein Lockfile eines anderen (Writer)Dokuments, das bei einem gestrigen Absturz von LO übrig blieb (werd ich nun löschen)

dewege Gravatar-Bilddewege ( 2019-12-04 11:17:19 +0100 )Bearbeiten

Hallo, ich konnte das auf meinem Testsystem nachstellen und für mich sieht (also eine Arbeitshypothese) das sehr nach einem Timing Problem aus. Ich vermute mal, dass der Aufruf, das PDF Dokument zu öffnen zu schnell kommt und SAMBA zum Zeitpunkt des Systemcalls die Datei zu öffnen, diese noch nicht kennt und daher einen Fehler auswirft (der von LibreOffice wiederum mehr schlecht als recht in einen Fehlertext transformiert wird). Das wird auch dadurch untermauert, dass ein Ausschalten der PDF Export-Option PDF-Dokument nach Export anzeigen (View PDF after export) den Fehler verhindert. Insofern ist es auch nicht, wie der Titel Deiner Frage und der Fehlermedlung vermuten läßt, das Speichern des PDF Dokuments sondern dessen (verfrühtes) Öffnen.

Aus meiner Sicht ein Bug der hier berichtet werden sollte (Der gleiche Test unter Windows führt übrigens zu keiner Fehlerausgabe: Mein SMB/CIFS Server läuft unter Linux).

Opaque Gravatar-BildOpaque ( 2019-12-04 12:26:46 +0100 )Bearbeiten

1 Antwort

0

geantwortet 2019-12-04 12:34:39 +0100

Opaque Gravatar-Bild

Hallo,

leider kann ich als Antwort nur einen Workaround anbieten (siehe meinen letzten Kommentar): Deaktiviere im PDF Export Dialog die Option PDF-Dokument nach Export anzeigen

Bildbeschreibung

Bearbeiten Melden löschen Link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2019-12-04 10:05:21 +0100

Angesehen: 22 Mal

Aktualisiert: Dec 04