Frage stellen
0

symbole im menu aktivieren Version: 6.4.4.2

gefragt 2020-07-18 21:53:51 +0200

haraldch Gravatar-Bild

updated 2020-07-19 09:32:24 +0200

PKG Gravatar-Bild

Hallo,

ich würde gerne wieder die Symbole im Menu aktivieren. Leider finde ich dazu keine Einstellmöglichkeit. Wie kann ich das aktiverien?

Vielen Dank für die Hilfe.

Liebe Grüße

Harald Christoffel

Bearbeiten Tags ändern Melden schließen vereinen löschen

2 Antworten

0

geantwortet 2020-07-19 02:24:49 +0200

Opaque Gravatar-Bild

updated 2020-07-19 16:58:37 +0200

Hallo,

dafür die Option Extras -> Optionen -> LibreOffice -> Ansicht -> Kategorie: Sichtbarkeit -> Auswahlliste: Symbole: verantwortlich. Wenn Automatisch bei Dir nicht funktioniert, wähle dort Anzeigen.

Bildbeschreibung

[Update für Mint 20 / GTK3]

Da unter GTK3 (und damit unter GNOME, MATE und Cinnamon) Icons in Menüs offensichtlich nicht unterstützt werden, kann man dies nur erreichen, in dem man LibreOffice mit dem KDE Frameworks 5 (kf5) startet. Dazu

  • sudo apt install libreoffice-kf5 (dies installiert zusätzlich eine ganze Reihe benötigter Bibliotheken des KDE Frameworks 5)
  • LibreOffice mit dem Befehl SAL_USE_VCLPLUGIN=kf5 libreoffice starten
  • Eintragen von export SAL_USE_VCLPLUGIN=kf5 in die Datei $HOME/.profile bewirkt, dass LibreOffice stets mit dem VCL:kf5 gestartet wird (Ein- und Ausloggen in/aus dem Desktop Manager erforderlich)
  • Die Menüs sind anschließend automatisch mit den Icons versehen und die in der ürsprünglichen Antwort gezeigte Option in den LibreOffice Einstellungen ist verfügbar.

Anmerkung Das VCL kf5 führt auch dazu, dass ein anderer Symbolstil defaultmäßig aktiv wird (bei mir ist das der Symbolstil Colibre. Gegebenenfalls unter Extras -> Optionen -> Ansicht -> Auswahlliste: Symbolstil einen anderen Symbolstil wählen.

PS: Falls Du auf macOS sein solltest ersetze im obigen Konfigurationspfad Extras -> Optionen durch LibreOffice -> Einstellungen

Ich hoffe, das hilt.

Bearbeiten Melden löschen Link mehr

Kommentare

Hallo, zuerst vielen Dank für die schnelle Antwort an einem Sonnabend! Das ist wirklich toll:

Ein paar Daten zum System. Computer Laptop HP Linux Mint 20

LibreOffice Version 6.4.4.2 CPU-Threads: 2; BS: Linux 5.4; UI-Render: Standard; VCL: gtk3; Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE Calc: threaded

C:\fakepath\Bildschirmfoto vom 2020-07-19 07-41-24.png

Dieses Menu gibt es in den Einstellungen nicht!

Was kann ich nun machen?

Vielen Dank für die Hilfe

haraldch Gravatar-Bildharaldch ( 2020-07-19 07:45:33 +0200 )Bearbeiten

Ich kann erst einmal bestätigen, dass es in der Mint 20 Version aus dem Distributions-Repository diese Einstellung nicht gibt (habe mir grade ein MINT 20 dazu installiert). Allerdings hege ich langsam die Vermutung, dass Du zuvor kein GTK3 basiertes System hattest (GNOME, MATE, Cinnamon), denn die Einstellung gibt es in keiner Version, auch auf meinem openSUSE nicht, sobald ich das VCL:gtk3 (kann man mit SAL_USE_VCLPLUGIN=gtk3 erzwingen) verwende. Ich kenne mich mit GTK3/GNOME basierten Anwendungen nicht allzu sehr aus, aber offensichtlich sieht das Design keine Menü-Icons vor und deshalb gibt es diese Option in LibreOffice auch nicht.

Hattest Du zuvor ein Windows oder KDE/Plasma basiertes System oder eine sehr altes GTK2 basiertes System, die die Ions in Menüs kennen und Du offensichtlich daran gewöhnt bist?


Siehe auch das Update in meiner Antwort speziell für Deinen Fall "Mint 20"

Opaque Gravatar-BildOpaque ( 2020-07-19 12:14:56 +0200 )Bearbeiten

Wie mache ich das genau? Terminal als Systemverwalter öffnen? Das kriege ich noch nicht so richtig hin.

Nein nicht als Systemverwalter - $HOME ist Dein Benutzerverzeichnis. Das machst Du benutzerspezifisch nur für Dich. Da ich keine Ahnung von Deinen Linux-Kenntnissen habe und auch nicht weiß, ob Du mit dem vi Editor umgehen kannst, ist es vielleicht das Einfachste wenn Du schlicht folgende 2 Befehle in einem Terminal ausführst (exakt so, wie sie da stehen, Du kannst die einfach kopieren, in Dein Terminal einfügen und ENTER drücken)

cp $HOME/.profile $HOME/.profile.backup.2020-07-19
(macht ein Backup, falls was schief gehen sollte)


echo "export SAL_USE_VCLPLUGIN=kf5" >>$HOME/.profile
(schreibt die benötigte Umgebungsvariable ans Ende der .profile datei - bitte unbedingt auf die doppelte Ausführung des Umleitungsoperators > achten)


Prüfung, ob das geklappt hat, mit: cat $HOME/.profile (die letzte Zeile sollte den Eintrag zeigen

Opaque Gravatar-BildOpaque ( 2020-07-19 18:03:43 +0200 )Bearbeiten

Hat nach Neustart funktioniert. Danke für die professionelle Hilfe. Leicht, verständlich und empathisch gut gemacht.

Schönen Sonntag.

haraldch Gravatar-Bildharaldch ( 2020-07-19 18:49:32 +0200 )Bearbeiten

Wenn's geholfen hat, wäre es nett wenn Du auf das kleine Häkchen (✔) direkt neben der Antwort (wird grün dabei) klicken würdest. Damit weiß dann jeder, dass hier eine Antwort zu finden ist. Danke ...

Opaque Gravatar-BildOpaque ( 2020-07-19 20:02:07 +0200 )Bearbeiten
0

geantwortet 2020-07-19 17:19:17 +0200

haraldch Gravatar-Bild

updated 2020-07-19 17:35:33 +0200

Hallo,

vielen Dank für die aufschlussreichen Informationen. Ich versuche es mit den Befehlen die Ihr mir angeben habt. Sollte das so funktionieren wäre das super.

Ich habe es gerade probiert mit den Einstellungen hat es geklappt. Allerdings konnte ich die dauerhafte Einstellungen nicht hinbekommen:

Eintragen von export SAL_USE_VCLPLUGIN=kf5 in die Datei $HOME/.profile bewirkt, dass LibreOffice stets mit dem VCL:kf5 gestartet wird (Ein- und Ausloggen in/aus dem Desktop Manager erforderlich) Die Menüs sind anschließend automatisch mit den Icons versehen und die in der ürsprünglichen Antwort gezeigte Option in den LibreOffice Einstellungen ist verfügbar.

Wie mache ich das genau? Terminal als Systemverwalter öffnen? Das kriege ich noch nicht so richtig hin.

Danke für die Hilfe.

Blockquote

Zur Info ich habe den Rechner seit ubuntu 8.3 und habe ca. vor 7 Jahren gewechselt auf Mint 13 über Mint 18 auf Mint 19 jetzt Mint 20.... Die Rechner werden auch dienstlich genutzt und da meine Rente in 11.2026 beginnt dacht ich Aktualisierung bis 2025 reicht doch :-)

Vielen Dank für die nette Unterstützung. Ich schreibe sollte alles erledigt sein. Ist dieser Fall dann als gelöst zu notieren? Wenn ja, wo bitte?

Danke für eine Information.

Gruß Harald Christoffel

Bearbeiten Melden löschen Link mehr

Kommentare

Wenn Du deine Frage als beantwortet betrachtest klick einfach auf das kleine Häkchen (✔) direkt neben der Antwort (wird grün dabei), die Dir geholfen hat. Das reicht dann...

Und bitte für's nächste Mal: Poste auf dieser Seite keine Antwort wenn Du nicht wirklich auf eine Frage antwortest sondern auf eine Antwort reagieren willst. Benutzer daszu die kommentieren Funktion, wie Du es schon beim letzten Mal gemacht hattest. Auf dieser Q&A Seite sind Antworten solchen Posts vorbehalten, die die Frage eines LibreOffice Benutzers lösen oder beantworten. Danke im Voraus ....

Opaque Gravatar-BildOpaque ( 2020-07-19 17:24:28 +0200 )Bearbeiten

Bitte lies im Kommentarbereich zu meiner Antwort weiter - ich will jetzt meinen obigen Kommentar nicht ad Absurdum führen in dem ich hier weiter schreibe ...

Opaque Gravatar-BildOpaque ( 2020-07-19 17:53:09 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2020-07-18 21:53:51 +0200

Angesehen: 63 Mal

Aktualisiert: Jul 19