Frage stellen
0

LO 6.4 meldet "SfxBaseModel::loadFromStorage: 0xf26"

gefragt 2021-01-12 12:22:21 +0100

frewer Gravatar-Bild

Seit kurzem meldet LO beim Versuch ein Formular zu öffnen den o.g. Text. Dies passierte zu erst nach einer ordnungsgenäßen Änderung des entsprechenden Formulars. Beim nächsten Öffnen wurde automatisch ein weiteres Formular, an dem keine Änderungen erfolgte, mit dem gleichen Fehler nicht mehr geöffnet. Gbt es dazu eine Hilfe, kann man die Formulare noch retten? Gruß Frewer Betriebssystem: WIN10 20H2 LibreOffice 6.4

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

2 Antworten

0

geantwortet 2021-01-13 13:18:40 +0100

frewer Gravatar-Bild

zunächst vielen Dank für Kommentar und Antwort. zum Kommentar von Robert: bei mir kann es nicht an Mängeln der Festplatte liegen, denn die Datenbank ist auf einer nagelneuen SSD gespeichert (und diese habe ich getestet).

Ein Versionsproblem ist möglich, da ich zunächst die Datenbank in LO 7. erstellt habe, dann wegen der Instabilität von LO 7 (während der Arbeit ist LO plötzlich weg und möchte beim Wiederöffnen die Datenbank wiederherstellen). D.h. LO läuft bei mir nicht stabil. Habe dann nach LO 6.4 gewechselt (wurde empfohlen auf der LO Download-Webseite für Privatanwender) und da ging es los, dass beim Ändern der Formulare plötzlich die o.g. Fehlermeldung auftrat und das dann auch, wenn ich zB mein Hauptformular garnicht angetastet habe. Was kann man tun? Nach erneutem Download von LO 7 geht jetzt garnichts mehr. Beim Öffnen eines Formulars meldet sich "Database noch nicht wiederhergestellt" und beim Aktivieren der Wiederherstellung geht ein leeres Fenster auf mit "Libre Office Base Keine Rückmeldung" und das wars dann. Kann das mit dem Betriebssystem WIN10 zusammenhängen, das automatisch von MS auf Version 20H2 "upgedatet" wurde? mfG Frewer

Bearbeiten Melden löschen Link mehr

Kommentare

Da gibt es anscheinend einiges an Stabilitätsproblemen zusammen mit WIN 10. Ich lese da inzwischen häufig Bugs (für Base), die unter Linux nicht vorhanden sind.

Was kannst Du tun?

LO 6.4.7.2 installieren und dann die Version in der *.odb-Datei ändern. Bitte nur mit einer Kopie der Datenbankdatei versuchen: Öffnen der Datenbankdatei in einem Packprogramm, öffnen der darin enthaltenen content.xml. Da recht weit oben office:version="1.3". Hier dann eine 1.2 draus machen. Dann stimmt die Version wieder mit der Überein, die zum Speichern des Formulars genutzt wurde.

RobertG Gravatar-BildRobertG ( 2021-01-13 18:13:18 +0100 )Bearbeiten

Hallo, habe das gemacht: mit 7zip eine Kopie erstellt, dann mit WORDPAD die content.xml geändert. So weit alles ok, aber wie komme ich jetzt wieder zur .odB Datenbank, die ich mit LO 6.4 öffnen kann? Ich habe nämlich jetzt einen Ordner mit "name-Kopie", den ich mit LO nicht öffnen kann und mit dem Pack-programm kann ich keine .odb erstellen (zumindest nicht mit meinem Wissensstand). Frewer

frewer Gravatar-Bildfrewer ( 2021-01-14 11:52:08 +0100 )Bearbeiten

Ich habe hier nur Linux zur Verfügung. Da öffnet mir das Packprogramm die *.odb-Datei zum Lesen. Ich kann dann auch die content.xml darin zum Schreiben öffnen und wieder abspeichern. Das bleibt immer im gleichen Format erhalten - eben als *.odb-Datei für das Datenbankmodul von LibreOffice.

Gegebenenfalls könntest Du mir die Datei per privater Mail zuschicken, wenn Dir die Daten nicht zu sensibel sind. Dann probiere ich das eben schnell für Dich.

RobertG Gravatar-BildRobertG ( 2021-01-14 18:44:00 +0100 )Bearbeiten

wie finde ich Deine mail-Adresse? Vielleicht erkennst Du dann ja die vielen Tips, die Du mir bereits früher gegeben hast. Die daten sind alle nur fiktiv. mfG Frewer

frewer Gravatar-Bildfrewer ( 2021-01-15 15:16:08 +0100 )Bearbeiten

Ich verweise da einfach einmal auf meine Homepage. Schau unter "Kontakt" nach.

RobertG Gravatar-BildRobertG ( 2021-01-16 20:25:21 +0100 )Bearbeiten
0

geantwortet 2021-01-12 12:41:52 +0100

RobertG Gravatar-Bild

Das kann ein Versionsproblem.

Wurde die Datei zwischendurch irgendwann einmal in LO 7.0 geöffnet und dort etwas an den Formularen geändert? Jetzt steht in der *.odb-Datei einmal, dass mit der ODF-Version 1.3 arbeitet, in den Formularen dann aber Abspeicherungen mit der ODF-Version 1.2 gemacht wurden. ODF-Version 1.3 kann LO 6.4 noch nicht.

Bearbeiten Melden löschen Link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2021-01-12 12:22:21 +0100

Angesehen: 27 Mal

Aktualisiert: Jan 13