Frage stellen
0

Ansichten in Base sind leer

gefragt 2014-08-28 17:12:23 +0200

icebear48 Gravatar-Bild

Mache ich da was falsch? Ich habe zwei Ansichten erstellt, die auch Ergebnisse bringen und in Berichten angewandt sind. Wenn ich sie nun zum Bearbeiten öffne, scheinen sie leer zu sein.

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Bitte gib die genaue Version deines Programms an (Hilfe > Info zu LibreOffice) und das Betriebssystem. Welche Datenbank-Engine benutzt du? Das steht in Base links unten in der Statuszeile.

Regina Gravatar-BildRegina ( 2014-08-29 14:11:37 +0200 )Bearbeiten

Version LibreOffice: Version: 4.3.0.4 Build-ID: 62ad5818884a2fc2e5780dd45466868d41009ec0 Ich habe Win 7 64bit installiert DB-Engine: Eingebettete Datenbank Die erstellten Ansichten (alle) erscheinen beim Öffnen zum Bearbeiten als leere Hülse. Wenn ich auf "Abfrage ausführen" klicke, kriege ich ein Fenster mit dem Hinweis: "Es fehlt eine Selektion". Dasselbe geschieht auch, wenn ich die Ansicht mit "in SQL-Ansicht bearbeiten" öffne.

icebear48 Gravatar-Bildicebear48 ( 2014-09-09 13:57:35 +0200 )Bearbeiten

Inzwischen habe ich 3 Ansichten erstellt. Als ich die 3. abgespeichrt hatte, wollte ich sie in veränderter Form unter einem anderen Namen abspeichern. Doch das geht leider nicht. Es hätte mir eine gangbare Umgehung des Problems geboten.

icebear48 Gravatar-Bildicebear48 ( 2014-09-09 13:59:34 +0200 )Bearbeiten

Kannst du die .obd Datei bereitstellen?

Regina Gravatar-BildRegina ( 2014-09-09 17:29:30 +0200 )Bearbeiten

Ich mache einen Schnappschuss von der View im Edit-Modus und im SQL-Modus. Wie bekomme ich die hier hinein oder angehängt. Ich scheine momentan blind zu sein.

icebear48 Gravatar-Bildicebear48 ( 2014-09-10 09:55:27 +0200 )Bearbeiten

Nun die Bilder über Antwort (Anhang): Da bekomme ich ein Fenster: "Three points required ..." Es scheint mir (noch) nicht gestattet zu sein. Gibt es einen anderen Weg?

icebear48 Gravatar-Bildicebear48 ( 2014-09-10 09:59:47 +0200 )Bearbeiten

Natürlich kann ich auch die .odb Datei zur Verfügung stellen. Sie enthält nur schon Daten von Personen.

icebear48 Gravatar-Bildicebear48 ( 2014-09-10 18:11:59 +0200 )Bearbeiten

Nun habe ich die Datenbank kopiert und weitestgehend geleert, so dass ich sie problemlos weitergeben kann. Der Fehler ist dadurch NICHT verschwunden!

icebear48 Gravatar-Bildicebear48 ( 2014-09-10 18:47:43 +0200 )Bearbeiten

Da ich hier keine Dateien, wohl aber links einstellen kann, habe ich die Snapshots und die fast leere Datenbank auf meine Website gestellt und fügen den Link hier ein: http://www.helmutlohkamp.de/?page_id=4

icebear48 Gravatar-Bildicebear48 ( 2014-09-10 19:09:35 +0200 )Bearbeiten

1 Antwort

0

geantwortet 2014-09-10 19:29:11 +0200

Regina Gravatar-Bild

Hallo icebear48, danke dass du die Datei bereitgestellt hast. Es liegt nicht an dir, sondern du hast einen Fehler gefunden. Ich kann bestätigen, dass die Edit-Dialoge leer sind. Ich sehe den Fehler in einer Version 4.3 und in der Entwickler-Version 4.4. In der Version 4.2.5 und in Apache OpenOffice ist alles in Ordnung. Du könntest eine solche Version parallel installieren oder eine portable Version benutzen, wenn es nötig wird eine View zu bearbeiten.

Bitte schreibe einen Bug-Report und hänge dort die Datei an.

Bearbeiten Melden löschen Link mehr

Kommentare

Hallo Regina, danke für die Unterstützung. Ich hoffe, dass der Fehler bald behoben werden kann, denn die bisherige Umgehungslösung hier war nicht sehr erfreulich. Momentan installiere ich gerade die Version 4.2.6 als portable auf einem Stick und werde das dann mal ausprobieren. Die Dateien auf meiner Website werde ich wieder löschen. Danke! Ciao.

icebear48 Gravatar-Bildicebear48 ( 2014-09-11 10:01:09 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2014-08-28 17:12:23 +0200

Angesehen: 684 Mal

Aktualisiert: Sep 10 '14