Frage stellen
1

Rahmen-Hintergrund dauerhaft farbig/schwarz hinterlegen

gefragt 2015-03-14 15:01:00 +0200

neuling75 Gravatar-Bild

Hallo Freunde,

ich habe die Libreoffice-Version 4.4.1.1 sowie das Betriebssystem Windows 7. Seit einiger Zeit ist bei mir ein Text-Dokument mit einem Rahmen nicht dauerhaft, d.h. selbst nach einer Speicherung, zu hinterlegen. Ich hatte hierzu schon in einem anderen Forum eine sinngemäße Anfrage gestartet. Leider kam nur eine Antwort und die war auch nicht hilfreich (sollte eine alte Version herunterladen - hat aber auch nicht geholfen). Somit gehe ich davon aus, dass das geschilderte Problem nicht bei anderen Anwendern gegeben ist, sondern dass dies prinzipiell nur bei mir gegeben ist.

Da ich mit meinen 77 Jahren am PC nicht besonders fit bin, so ist meine Frage zum dargestellten Problem, was könnte ich tun und/oder überprüfen, um das sehr lästige Problen zu beseitigen.

neuling75

Bearbeiten Tags ändern Melden schließen vereinen löschen

4 Antworten

0

geantwortet 2015-03-14 22:06:05 +0200

Lupp Gravatar-Bild

updated 2015-03-18 00:26:47 +0200

Kann es ein Problem mit dem Speicherformat (evtl. DOC oder DOCX?) sein?. Die allgemeine Empfehlung ist, bei Textdokumenten mit LibreOffice nur ODT /OTT zu verwenden, wenn kein zwingender Grund dagegensteht.

Wenn ein Fehler dieser Art ausgeschlossen ist, kann es schwer sein, weiter zu helfen, ohne ein Beispieldokument zur Verfügung zu haben, bei dem das Problem auftritt.

... Rahmen-Hintergrund dauerhaft farbig/schwarz hinterlegen ...

Wurde das mit > 'Format' > 'Absatz' > 'Fläche' versucht? (Irrelevant)

Entsprechend meinem Kommentar zu Reginas Antwort hänge ich hier ein kleines Beispiel an, in dem ein Textrahmen durch Anwendung einer benannten Vorlage auf rote Fläche gesetzt ist. (Erstellt und getestet mit V4.4.2.1.) BoxFarbeTest002.odt

Bearbeiten Melden löschen Link mehr

Kommentare

Also, ich speichere meine Textdokumente grundsätzlich nur im Format odt oder ott ab. Egal, ob ich den Rahmen oder den Absatz im Rahmen markiere mit/über Format > Absatz > Fläche geht bei mir überhaupt nichts.

Ich würde gern ein Beispiel-Dokument in das Forum einstellen. Nur leider weiß ich im Monent nicht wie ich das anstellen muß (Entschuldigung, mein Alter verursacht da wohl das Problem).

Was könnte ich sonst noch tun. Weiß jemand einen Rat?

neuling75

neuling75 Gravatar-Bildneuling75 ( 2015-03-15 10:15:46 +0200 )Bearbeiten

Hallo Freunde,

ich hatte ja die Anfrage bezüglich dauerhaften farbigen Rahmen-Hinterlegung gestellt. Jetzt kann ich der Diskussion irgendwie nicht mehr ganz folgen. Wenn ich Eure Kommentare nur halbwegs verstehe, dann habt Ihr doch mit der Rahmen-Hinterlegung irgendwie Probleme, oder? Ich gehe vorerst davon aus, dass dieses Problem z.Zt. systembedingt ist. Der Vorschlag von Regina ein Bitmap-Bild zuerstellen usw., obwohl sicher etwas umständlich, löst ersteinmal mein Problem.

neuling75 Gravatar-Bildneuling75 ( 2015-03-19 09:16:40 +0200 )Bearbeiten

Ich bin bei der Rahmen-Umrandung auf ein Phänomen gestossen, und zwar wenn eine doppel-linige Umrahnung mit unterschiedlichen Linien-Dicken gewählt wird (>. 2), dann laufen die Liniien-Dicken nicht umlaufend. Wie ist den das Problem zu lösen?

neuling75 Gravatar-Bildneuling75 ( 2015-03-20 10:48:53 +0200 )Bearbeiten

@neuling75: Hat das auch mit Persistenz zu tun? Eigentlich sollte es auf alle Fälle unter einem neuen Betreff gebracht werden.

In der Sache: Ich kann das (wieder für V4.4.2.1) bestätigen. Es is m.E. eindeutig ein "Bug". Jemand hat wohl bei der Modernisiering des Codes "außen" mit "oben und links" durcheinander gebracht. Das schlägt dann anscheinend bei allen Elementen, die eine Umrandung haben können, durch. Vgl. diesen Bug.

Lupp Gravatar-BildLupp ( 2015-03-20 11:14:18 +0200 )Bearbeiten

Ein (leider sehr unhandlicher) "Workaround": Den unteren und den rechten Rand gesondert setzen. Dass hier dieselben Symbole für die Art des Randes (bei Doppellinien) traditionell umgekehrt interpretiert werden, als wie man es für einen Rundumrand erwarten würde, ist wohl auch der Hintergrund des Problems. Hätte man hier von vornherein in "außen / innen" differenziert, statt solche ohnehin kaum klar erkennbare Bildchen zu benutzen, gäbe es das Problem nicht.

Lupp Gravatar-BildLupp ( 2015-03-20 11:45:19 +0200 )Bearbeiten

Hallo Lupp,

der Ordnung halber möchte ich mich bei Dir noch einmal melden und auch bedanken für Deinen Tipp den Rahmen mit 4-seitig doppelten Rahmenlinien-Dicken zu erstellen. Das Verfahren sst natürlich sehr intensiv bzw. umständlich, aber es geht. Ich hoffe nur, dass auch dieses Problem eines Tages bei LibreOffice beseitigt wird.

Grüße von neuling 75

neuling75 Gravatar-Bildneuling75 ( 2015-03-26 16:19:51 +0200 )Bearbeiten
0

geantwortet 2015-03-16 21:56:04 +0200

Regina Gravatar-Bild

updated 2015-03-17 00:08:02 +0200

Das ist ein Bug, es liegt nicht an dir, siehe tdf#86578 und zahlreiche Duplikate. Die Hintergrundfarbe wird immer auf weiß gesetzt.

Als Workaround kannst du in einem der Fremdformate speichern (z.B. docx, doc, rtf) oder du kannst dir ein kleines Bild herstellen und dieses für den Hintergrund verwenden. 8x8 Pixel aus dem Bitmap-Tab des Flächen-Dialogs genügen.

RahmenMitFarbe.odt

Bearbeiten Melden löschen Link mehr

Kommentare

Also, entweder bin ich terminologisch verirrt. ...

Ich kann das, jedenfalls mit V4.4.2.1 unter Win 8.1, nicht verifizieren.

Lupp Gravatar-BildLupp ( 2015-03-16 23:25:27 +0200 )Bearbeiten

Ich habe eine Datei hochgeladen. Probiere es mal damit. Ich sehe den Fehler in einer LO4.4.0 und einer daily LO4.5. In LO4.2 ist es noch in Ordnung und auch AOO hat keine Schwierigkeiten mit der Datei.

Regina Gravatar-BildRegina ( 2015-03-17 00:10:26 +0200 )Bearbeiten

@Regina Ich muss mich für unnötige Arbeit, die ich dir gemacht habe entschuldigen.

Meine "Hintergrundfarbe" war im Test einmal für den Absatz gewählt statt für den Rahmen, im anderen Fall (Bildrahmen) war sie ein Verlauf. Ist das das Alter?

Lupp Gravatar-BildLupp ( 2015-03-17 11:50:23 +0200 )Bearbeiten
0

geantwortet 2015-03-15 15:52:23 +0200

Lupp Gravatar-Bild

updated 2015-03-17 19:11:24 +0200

Hochladen einer Beispieldatei ("Karma" reicht jetzt!):

Frage bearbeiten, Büroklammer (für "Anhang") über dem Editor anklicken, 'Durchsuchen' (Datei vom eigenen Computer auswählen), Bestätigen ...

Gruß vom jungen Kollegen (70).

(Dank Regina sollte ich jetzt wirklich bei der Sache sein.)

Statt "Workaround" für die Rettung der Direktformate empfehle ich die Arbeit mit benannten Rahmenformaten: F11, Rahmenvorlagen, z.B. von 'Rahmen' eine neue Vorlage ableiten. Auswahl unten auf 'Alle' stellen, Den Textrahmen wieder wählen und durch Doppelcklick auf dien Namen der neuen Rahmenvorlage diese anwenden.

Das übersteht Speichern und Wiederladen in odt.

Bearbeiten Melden löschen Link mehr

Kommentare

Das kann ich leider nicht bestätigen. Bei mir ist nach dem Öffnen mit LO4.5 alles weiß und zwar wurde selbst die Vorlage verändert. Die Farbe weiß ist also nicht nur als harte Formatierung falsch. Das Problem entsteht hier, wenn ich die Datei mit LO4.2 speicher und dann in LO4.5 öffne. Irgendwie alles sehr fehlerhaft.

Regina Gravatar-BildRegina ( 2015-03-17 22:12:01 +0200 )Bearbeiten

Die jüngste Version, die ich habe, ist 4.4.2.1. Mit der habe ich probiert. Um neue Missverständnisse unwahrscheinlicher zu mache, hänge ich ein Beispiel an meine Antwort unten an.

Lupp Gravatar-BildLupp ( 2015-03-18 00:22:24 +0200 )Bearbeiten

Ja mit Style geht es schon besser, solange man innerhalb von LO4.5 bleibt. So ganz in Ordnung ist es aber nicht. Es wird zwar richtig die Farbe im Style gespeichert, aber sie wird vorne im Organizer-Tab nicht angezeigt. Bei LO4.2 und AOO4.2 wird die Farbe dort angezeigt. Wenn man allerdings zwischen LO4.5 und ältern Versionen hin-und-her speichert, tritt der Farbverlust trotz Style auf.

Regina Gravatar-BildRegina ( 2015-03-18 19:54:36 +0200 )Bearbeiten
0

geantwortet 2015-03-17 09:46:08 +0200

neuling75 Gravatar-Bild

Hallo Regina,

Dein Tipp bzw. Deine Empfehlung war erst einmal sehr gut. So habe ich das Problem lösen können, d.h. nach der Dokumenten-Abspeicherung und -Öffnun bleibt der Rahmen farbig.

Allerdings ist diese Funktions-Weise ja etwas umständlich und ob ich meine anderen "Problemchen" damit sinngemäß lösen kann werde ich sehen. Weiter verstehe ich Dich so, dass wahrscheinlich mein jetziges Problem in der Kombination von Betriebssystem und LibreOffice-Version liegen könnte?

Wenn das so wäre, dann wundert mich, dass ich in den Foren hierzu nicht mehr gelesen habe.

An Deiner Empfehung hat mich ganz besonders gefreut, dass ich so die Möglichkeit habe mir eigene Rahmen-Hintergründe zu gestalten. Problem bleibt nur, dass ich diese offensichtlich nicht unter Rahmen > Bereich/Feld abspeichern kann, d.h. die Abspeicherung erfolgt z.Zt. bei mir unter "Bilder". Oder gibt es doch eine Möglichkeit?

Abschließend, vielleicht gibt es bald eine neue LibreOffice-Version bei der das Problem nicht mehr gegeben ist ( ... und damit jedoch ein anderes)

Herzlichen Dank und liebe Grüße von neuling75

Bearbeiten Melden löschen Link mehr

Kommentare

Mit benannten Rahmenformaten passiert der Fehler nicht! Benannte Formate statt der Direkformatierung zu benutzen ist ohnehin oft von Vorteil.

Der Dialog für Formatvorlagen lässt sich mit F11 aufrufen. Vom vorgegebenen 'Rahmen' kannn man ein neues Format ableiien. Um es dann auch verwenden zu können, sollte man die Auswahl im Dialog ganz unten auf Äalle' stellen. Benutzung von Fremdformaten ist nicht nötig.

Lupp Gravatar-BildLupp ( 2015-03-17 19:04:33 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

Statistik

Gefragt: 2015-03-14 15:01:00 +0200

Angesehen: 517 Mal

Aktualisiert: Mar 18 '15