Frage stellen
0

Calc: SVERWEIS findet EAN in Tabelle nicht (MS Excel funktioniert)

gefragt 2015-07-08 12:59:26 +0100

EnzephaloN Gravatar-Bild

Hallo

Ich habe eine Tabelle die in 35000 Zeilen Produkte, deren EAN und deren Preis beinhaltet. Hier zwei exemplareische Zeilen:

200340 | 4001617204429 | Artikel A | 13,99 | 200340

200341 | cv200341 | Artikel B | 13,99 | 200341

Nun suche ich in einem anderen Tabellenblatt mit der SVERWEIS-Funktion in Spalte B nach dem EAN um dann die restlichen Produktinformationen auszugeben:

=WENN(NICHT(A2=0);SVERWEIS(A2;ARTIKEL!B$1:D$29998;2;FALSCH);"")

SVERWEIS funktioniert hier für alle Werte in Spalte B die die Form cv###### haben (von uns selbst generierte EANs). Für reguläre EAN-Werte wie zB 4001617204429 funktioniert SVERWEIS nicht - es wird nichts gefunden. Die gleiche Datei hat in MS Excel perfekt funktioniert, in Calc funktioniert es leider nicht. Es spielt auch keine Rolle welche Formatierung die Spalte B hat (TEXT oder ZAHL oder BENUTZERDEFINIERT).

Hat jemand eine Idee wie es trotzdem funktionieren könnte?

Johannes

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Kann ich hier nicht nachvollziehen. Allerdings musste ich auch das Ausrufezeichen nach "ARTIKEL!" durch einen Punkt ersetzen.

Meine Version: LO 4.4.4.3, OpenSUSE 13.2, 64bit rpm Linux.

Vielleicht kannst Du einmal ein kleines Beispiel irgendwo hoch laden?

Gruß

Robert

RobertG Gravatar-BildRobertG ( 2015-07-09 08:22:58 +0100 )Bearbeiten

1 Antwort

0

geantwortet 2015-07-09 14:19:46 +0100

Lupp Gravatar-Bild

Abgesehen davon, dass die Verwendung eines fremden Dateiformats (hier xls oder xlsx?) wohl selten eine gute Idee ist, funktioniert das eigentlich, wie auch @RobertG schon festgestellt hat. Die Bedingung würde ich allerdings anders wählen. Soll denn A2=0 hier auf "Zelle A2 leer" testen? Der Zahlenwert ist doch uninteressant! Das ist zumindest fehleranfällig. Ich habe den deutschen Funktionsnamen nicht parat, aber wenn du das angehängte Beispiel mit entsprechender Spracheinstellung öffnest, wird er ja angezeigt. Auch ein Test mit A2="" wäre eher verlässlich.

Das angehängte Beispiel ask52932DeDatenAuswahl001.ods demonstriert auch noch ein paar Kleinigkeiten aus meiner "Trickkiste", die man freilich erst anwenden sollte, wenn sie wirklich verstanden sind. Dann sind sie aber schon nützlich. Grundsätzlich würde ich auch damit rechnen, dass in der Realität nicht nur 2 Datenspalten abgefragt werden. Je mehr Datenfelder man selektieren will, um so ungünstiger wird die Effizienz der Verwendung von SVERWEIS (neben anderen Nachteilen). Die Suche nach der passenden Datenzeile muss nämlich für jede Zelle, die SVERWEIS anwendet neu durchgeführt werden (je 30000 Tests, wenn's ungünstig kommt). Die Zeile des benötigten Datensatzes einmal in einer Hilfsspalte zu suchen, und das Ergebnis mehrfach anzuwenden, ist logisch klarer, und arbeitet effizienter.

Bearbeiten Melden löschen Link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

2 Beobachter

Statistik

Gefragt: 2015-07-08 12:59:26 +0100

Angesehen: 461 Mal

Aktualisiert: Jul 09 '15