Frage stellen
0

Nach Wechsel von OpenOffice auf LibreOffice funktionieren externe Verknüpfungen nicht mehr

gefragt 2016-12-22 15:34:59 +0100

zahlendreer Gravatar-Bild

Bisher haben externe Verknüpfungen in Verbindung mit sverweis(), wverweis(), summewenn(), wenn() in OpenOffice einwandfrei funktioniert. Nach dem Wechsel auf LibreOffice funktionieren diese externe Verknüpfungen auf .csv Dateien nicht mehr!

Woran liegt das in LibreOffice. Gibt es hier einen BUG?

edit retag flag offensive close merge delete

Comments

Version? OS?
Es gibt Bugs bezüglich Einbindung von Csv. Ich habe aber keinen rechten Überblick. Wie sieht denn eine deiner SVERWEIS-Formeln genau aus? (Bitte Werkzeug 'Vorformatierter Text' benutzen!)
Ist die Csv "im Netz"? Kannst du sie irgendwie zur Verfügung stellen? (Sonst Nebel hier!)

Lupp Gravatar-BildLupp ( 2016-12-22 16:17:18 +0100 )edit

Es sind wverweis(), sverweis(), summewenn() wie zum Beispiel: =SVERWEIS($A5;'file:///T:/VM_Anzahl_Bestaende102016.ods'#$Tabelle1.$A$4:$Z$200;VERGLEICH(E$4;'file:///T:/VM_Anzahl_Bestaende102016.ods'#$Tabelle1.$A$4:$Z$4;0);0) oder =SUMMEWENN('file:///T:/KGB_GA_KK_SPV.csv'#$Tabelle1.$A$2:$A$5000;$A5;'file:///T:/KGB_GA_KK_SPV.csv'#$Tabelle1.$G$2:$G$5000) Es ist die aktuellste LO Version unter Windows 7

zahlendreer Gravatar-Bildzahlendreer ( 2016-12-23 14:25:57 +0100 )edit

Was hat das mit einer Csv_Datei zu tun?

Lupp Gravatar-BildLupp ( 2016-12-23 17:31:07 +0100 )edit
0

geantwortet 2016-12-23 18:40:08 +0100

Lupp Gravatar-Bild

updated 2016-12-23 18:41:52 +0100

[Für einen Helfer ist der Zeitaufwand, ein extra Beispiel zu erstellen, unangemessen. Was "die aktuellste Version" von LibO ist, ändert sich ziemlich oft. Die Versionen haben Nummern (4 Stufen, ggf. mit Zusatz).]

Ich habe das mit einem etwas vereinfachten Beispiel mit V5.2.2.2 und auch mit V5.3.0.0beta2 jeweils x64, Win 10 getestet. Die entsprechende Formel funktioniert wie sie soll. Das bleibt auch so wenn ich beide Dateien zusammen in unveränderter Relation woanders hin verlege.

Das im obigen Kommentar des OQ gegebene Beispiel legt die Vermutung nahe, dass die externe Datei, auf die zugegriffen werden soll, auf einem "Removable Drive" liegt, der von Win den LWBst T zugeordnet bekam. Solche Zuordnungen können geändert werden, nach meiner Erfahrung manchmal sogar wenn sie eigentlich fixiert sind (Konflikte!). Externe Links im Dateisystem sollten deshalb nur verwendet werden, wenn Quelle und zugreifende Datei in der selben Partition des selben Datenträgers liegen. Bitte nachprüfen ob T:/VM_Anzahl_Bestaende102016.ods tatsächlich mit genau diesem Pfad existiert.

edit flag offensive delete link mehr
0

geantwortet 2016-12-28 13:08:50 +0100

zahlendreer Gravatar-Bild

Das Problem ist, dass OpenOffice nicht vorhandene Verweise #NV anderst behandelt. Bisher konnten #NV Werte mit der Funktion N() in eine 0 umgewandelt werden. LibreOffice akzeptiert das anscheinend nicht mehr. Wenn ich die Formeln wie folgt umbaue: Wenn(ISTNV(Formel);0;Formel) ; dann funktionieren viele Verweise wieder.

Ein anderes Problem waren Verweise()/Vergleich() auf leere Zellen. In einem Verweis wurde bisher die erste leere Zelle eines Bereiches wie 0 behandelt. z. Bsp. sverweis(0;Bereich;1;0) hat als Ergebnis die erste leere Zeile als Ergebnis geliefert. LibreOffice interpretiert das nicht mehr so.

edit flag offensive delete link mehr

Comments

(NV ist die Entsprechung von NA: "not available", also "Nicht Verfügbar".)
Die jüngste Version von LibO, die den beschriebenen Ausweg enthielt war 3.5. Bereits 3.6 (2012-08-09) gab spezifikationsgemäß den NA-Fehler weiter.
Ab V4.0 (2013-02-01) waren dann die Funktionen IFNA WENNNV und IFERROR WENNFEHLER implementiert, die eine klarere Behandlung dieser Situationen ermöglichen und keine Doppelberechnung des Kernausdrucks erfordern. =WENNNV(Formel;0) genügt für obiges Beispiel.

Lupp Gravatar-BildLupp ( 2016-12-28 17:36:51 +0100 )edit

Die fast aktuelle Version 4.1.2 von Apache OpenOffice liefert zwar immer noch (spezifikationswidrig) N(NV())=0 , (Echt) leere Zellen werden aber mit VERGLEICH(0; Bereich; 0) nicht gefunden. Bei Zellen, die den leeren Text als Ergebnis besitzen, war das ohnehin nie der Fall.

Lupp Gravatar-BildLupp ( 2016-12-28 17:47:58 +0100 )edit
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 follower

Stats

Asked: 2016-12-22 15:34:59 +0100

Seen: 116 times

Last updated: Dec 28 '16