Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

This is actually a Keyboard / Operating system setup question. The Alt-Gr + key is read by the keyboard/operating system and passed to LibreOffice, it is not decided by LibreOffice. The topic is discussed in the topic https://ask.libreoffice.org/en/question/71892/how-do-i-type-a-simple-umlaut-in-libre-office/ The note below work on my Linux Mint system for all the software and all my versions of LibO (EN-GB) 4.0, 5.3, 5.4. The key is actually understanding the purpose of Alt-Gr. It applies to the versions of Windows that have a Alt-Gr (Right Alt key). Alt-Gr or Right-Alt is not the same as Alt but on the right hand side.

Briefly, the keyboard has four levels for entering characters.

My default keyboard is English UK extended Winkeys

Level 1 Lowercase Letter (a c d e etc.. for example)

Level 2 Uppercase Shift + letter (A C D E)

Level 3 Alt-Gr (right Alt) + letter (depending on keyboard for me á ç ð é ) Level 4 Alt-Gr Shift + letter (Á Ç Ð É)

Using the same keyboard but changing the setting to American International gives

                    a c d e    A C D E    á © ð é    Á ¢ Ð É

Swiss German a b d e A B D E æ ¢ ð € Æ ’ Ð E

Irish a c d e A C D E á ̧ð é   Á ¸ Ð É

I hope this provides a little information. In America, a Windows system is often set to ignore the level 3 and 4 so they struggle to put in accented characters and Alt-Gr is unpredictable. always check that the keyboard is set to International.