Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

LO Writer can handle multi-language documents without objecting, i.e. without being confused by spell-checking or other utilities, provided the current language is indicated to LOW.

Language is an attribute of paragraph style which you find in the Fonts tab of the style dialog.

In your case, if this document is written in Dutch, set Default Style language to Dutch and it will propagate to all other styles. You do it like that:

  1. Show the styles navigator with Format>Styles & Formatting or F11
  2. Right-click on Default Style and choose Modify...
  3. Got ot Font tab
  4. In the Language drop-down menu, select Dutch (BE and NL variants are available)
  5. Click OK

Note: If the language name is not tagged with a blue tick+ABC, the language pack is not installed. It only means that spell-checking will not be done.

If you intend to use Dutch for all your documents, define Dutch as the default:

  1. Open the general settings dialog with Tools>Options
  2. Select Language Settings>Settings
  3. Choose your default language in Default languages for documents/Western
  4. Push OK
  5. Close and restart LO Writer to make sure

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

LO Writer can handle multi-language documents without objecting, i.e. without being confused by spell-checking or other utilities, provided the current language is indicated to LOW.

Language is an attribute of paragraph style which you find in the Fonts tab of the style dialog.

In your case, if this document is written in Dutch, set Default Style language to Dutch and it will propagate to all other styles. You do it like that:

  1. Show the styles navigator with Format>Styles & Formatting or F11
  2. Right-click on Default Style and choose Modify...
  3. Got ot Font tab
  4. In the Language drop-down menu, select Dutch (BE and NL variants are available)
  5. Click OK

Note: If the language name is not tagged with a blue tick+ABC, the language pack is not installed. It only means that spell-checking will not be done.

If you intend to use Dutch for all your documents, define Dutch as the default:

  1. Open the general settings dialog with Tools>Options
  2. Select Language Settings>Settings
  3. Choose your default language in Default languages for documents/Western
  4. Push OK
  5. Close and restart LO Writer to make sure

EDIT:

There is a way to change the caption to anything you like, but it is only a workaround because the caption feature does not take into account the currently selected writing language around the point of insertion.

The first time you insert a caption (Insert>Caption...), change the Category in the dialog: put the cursor in the text box and replace the word here, e.g. tekst or illustratie and proceed as usual.

Next time you insert a caption, the previous category is preselected.

Even better, your custom category persists between sessions. You'll find it in the drop-down menu associated with the Category text box.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

LO Writer can handle multi-language documents without objecting, i.e. without being confused by spell-checking or other utilities, provided the current language is indicated to LOW.

Language is an attribute of paragraph style which you find in the Fonts tab of the style dialog.

In your case, if this document is written in Dutch, set Default Style language to Dutch and it will propagate to all other styles. You do it like that:

  1. Show the styles navigator with Format>Styles & Formatting or F11
  2. Right-click on Default Style and choose Modify...
  3. Got ot Font tab
  4. In the Language drop-down menu, select Dutch (BE and NL variants are available)
  5. Click OK

Note: If the language name is not tagged with a blue tick+ABC, the language pack is not installed. It only means that spell-checking will not be done.

If you intend to use Dutch for all your documents, define Dutch as the default:

  1. Open the general settings dialog with Tools>Options
  2. Select Language Settings>Settings
  3. Choose your default language in Default languages for documents/Western
  4. Push OK
  5. Close and restart LO Writer to make sure

EDIT:

There is a way to change the caption to anything you like, but it is only a workaround because the caption feature does not take into account the currently selected writing language around the point of insertion.

The first time you insert a caption (Insert>Caption...), change the Category in the dialog: put the cursor in the text box and replace the word here, e.g. tekst or illustratie and proceed as usual.

Next time you insert a caption, the previous category is preselected.

Even better, your custom category persists between sessions. You'll find it in the drop-down menu associated with the Category text box.

There's however a limitation to this work around: the category can only be a single word. No way to use spaces in the name. There's no free meal!

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

LO Writer can handle multi-language documents without objecting, i.e. without being confused by spell-checking or other utilities, provided the current language is indicated to LOW.

Language is an attribute of paragraph style which you find in the Fonts tab of the style dialog.

In your case, if this document is written in Dutch, set Default Style language to Dutch and it will propagate to all other styles. You do it like that:

  1. Show the styles navigator with Format>Styles & Formatting or F11
  2. Right-click on Default Style and choose Modify...
  3. Got ot Font tab
  4. In the Language drop-down menu, select Dutch (BE and NL variants are available)
  5. Click OK

Note: If the language name is not tagged with a blue tick+ABC, the language pack is not installed. It only means that spell-checking will not be done.

If you intend to use Dutch for all your documents, define Dutch as the default:

  1. Open the general settings dialog with Tools>Options
  2. Select Language Settings>Settings
  3. Choose your default language in Default languages for documents/Western
  4. Push OK
  5. Close and restart LO Writer to make sure

EDIT:

There is a way to change the caption to anything you like, but it is only a workaround because the caption feature does not take into account the currently selected writing language around the point of insertion.

The first time you insert a caption (Insert>Caption...), change the Category in the dialog: put the cursor in the text box and replace the word here, e.g. tekst or illustratie and proceed as usual.

Next time you insert a caption, the previous category is preselected.

Even better, your custom category persists between sessions. You'll find it in the drop-down menu associated with the Category text box.

There's however a limitation to this work around: workaround: the category can only be a single word. No way to use spaces in the name. There's no free meal!

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

LO Writer can handle multi-language documents without objecting, i.e. without being confused by spell-checking or other utilities, provided the current language is indicated to LOW.

Language is an attribute of paragraph style which you find in the Fonts tab of the style dialog.

In your case, if this document is written in Dutch, set Default Style language to Dutch and it will propagate to all other styles. You do it like that:

  1. Show the styles navigator with Format>Styles & Formatting or F11
  2. Right-click on Default Style and choose Modify...
  3. Got ot Font tab
  4. In the Language drop-down menu, select Dutch (BE and NL variants are available)
  5. Click OK

Note: If the language name is not tagged with a blue tick+ABC, the language pack is not installed. It only means that spell-checking will not be done.

If you intend to use Dutch for all your documents, define Dutch as the default:

  1. Open the general settings dialog with Tools>Options
  2. Select Language Settings>Settings
  3. Choose your default language in Default languages for documents/Western
  4. Push OK
  5. Close and restart LO Writer to make sure

EDIT:

There is a way to change the caption to anything you like, but it is only a workaround because the caption feature does not take into account the currently selected writing language around the point of insertion.

The first time you insert a caption (Insert>Caption...), change the Category in the dialog: put the cursor in the text box and replace the word here, e.g. tekst or illustratie and proceed as usual.

Next time you insert a caption, the previous category is preselected.

Even better, your custom category persists between sessions. You'll find it in the drop-down menu associated with the Category text box.

There's however a limitation to this workaround: the category can only be a single word. No way to use spaces in the name. There's no free meal!meal! You can circumvent this limitation by activating the auto-insertion feature, but you must plan ahead your document to avoid chaos and later tedious manual patches:

  1. In the caption dialog, push the Auto... button
  2. Click on the desired object types at left
  3. Select then each one in its turn and adjust the settings for this type; in particular, you can customize the category and any sentence (= sequence of words) can be used.

When a new checked object (frame, picture, drawing, diagram are the most interesting) is inserted, the customised caption is automatically added. If you do not like automatic insertion, do it once, then disable it. The category with spaces is now entered in the drop-down menu and can later be selected at will. Of course, remove the unnecessary caption.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.