Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi qubit, thank you very much foy your answer pal. Yeah, I would like to know how to put the option to open as read-only by default in all LibreOffice aplications (Writer, Impress, Calc, Draw, Base and Math) using LinuxMint for when a user opens an odt., odp., .ods and other, double-clicking on the document and taking LibreOffice as default application can not edit the content as this I have to implement in the computer lab where I am working on 40 computers and users that only view their documents but do not come with LibreOffice editing because it is a space to explore and visualize all types of documents around. Following your intuition, i try execute the next orders in the terminal for remove write privileges in user, group and others:

root@debian:/home/jonathan# chmod ugo-w /usr/bin/libreoffice

but in this directory libreoffice is a symbolic link, so then I try in the .config direcotry of my home:

root@debian:/home/jonathan# chmod -R ugo-w /home/jonathan/.config/libreoffice/

but when I try to open LibreOffice in general or a .odt file directly, the LibreOffice appear, the window open and inmediatly closes, so when I restore the original privileges:

root@debian:/home/jonathan# chmod -R ugo+w /home/jonathan/.config/libreoffice/

I can use LibreOffice normally again Do yo know what I am doing wrong? Thanks

Hi qubit, thank you very much foy your answer pal. Yeah, I would like to know how to put the option to open as read-only by default in all LibreOffice aplications (Writer, Impress, Calc, Draw, Base and Math) using LinuxMint for when a user opens an odt., odp., .ods and other, double-clicking on the document and taking LibreOffice as default application can not edit the content as this I have to implement in the computer lab where I am working on 40 computers and users that only view their documents but do not come with LibreOffice editing because it is a space to explore and visualize all types of documents around. Following your intuition, i try execute the next orders in the terminal for remove write privileges in user, group and others:

root@debian:/home/jonathan# chmod ugo-w /usr/bin/libreoffice

but in this directory libreoffice is a symbolic link, so then I try in the .config direcotry directory of my home:

root@debian:/home/jonathan# chmod -R ugo-w /home/jonathan/.config/libreoffice/

but when I try to open LibreOffice in general or a .odt file directly, the LibreOffice appear, the window open and inmediatly closes, so when I restore the original privileges:

root@debian:/home/jonathan# chmod -R ugo+w /home/jonathan/.config/libreoffice/

I can use LibreOffice normally again Do yo know what I am doing wrong? Thanks

Hi qubit, thank you very much foy your answer pal. Yeah, I would like to know how to put the option to open as read-only by default in all LibreOffice aplications (Writer, Impress, Calc, Draw, Base and Math) using LinuxMint for when a user opens an odt., odp., .ods and other, double-clicking on the document and taking LibreOffice as default application can not edit the content as this I have to implement in the computer lab where I am working on 40 computers and users that only view their documents but do not come with LibreOffice editing because it is a space to explore and visualize all types of documents around. Following your intuition, i try execute the next orders in the terminal for remove write privileges in user, group and others:

root@debian:/home/jonathan# chmod ugo-w /usr/bin/libreoffice

but in this directory libreoffice is a symbolic link, so then I try in the .config directory of my home:

root@debian:/home/jonathan# chmod -R ugo-w /home/jonathan/.config/libreoffice/

but when I try to open LibreOffice in general or a .odt file directly, the LibreOffice logo appear, the window open and inmediatly closes, so when I restore the original privileges:

root@debian:/home/jonathan# chmod -R ugo+w /home/jonathan/.config/libreoffice/

I can use LibreOffice normally again Do yo know what I am doing wrong? Thanks