Ask Your Question

Revision history [back]

A workaround to achieve what the OP is asking, i.e. footnote anchor in square brackets like this [1], is to use the Alternative dialog Find & Replace for Writer (AltSearch) Add-on:

  • Open the addon and in the "Search for:" field enter "[::Footnote::]" (without quotes)

  • In the "Replace" field enter " [&]" (without quotes: notice the space before the opening bracket in case your footnote anchors are attached to the previous char)

ATTENTION: each replace 'consumes' and undo step so the change might be irreversible, better save your file before proceeding!

  • Make sure "Regular Expressions" checkbox is selected

  • Hit "Replace All"

Alternative Find and Replace dialog

  • Now you should have all footnotes anchors surrounded by square brackets

image description

  • to remove the superscript style, edit the "Footnote Anchor" style and set the Position to "Normal" in the Position tab.

image description

Here is a simple test document which also has the footnote paragraph at the end, also featuring square brackets: C:\fakepath\footnotes_brackets_test.odt

Still a workaround... but at least gets the job done. Hope this helps.

A workaround to achieve what the OP is asking, i.e. footnote anchor in square brackets like this [1], is to use the Alternative dialog Find & Replace for Writer (AltSearch) Add-on:

  • Open the addon and in the "Search for:" field enter "[::Footnote::]" (without quotes)

  • In the "Replace" field enter " [&]" (without quotes: notice the space before the opening bracket in case your footnote anchors are attached to the previous char)

ATTENTION: each replace 'consumes' and an undo step so the change might be irreversible, better save your file before proceeding!

  • Make sure "Regular Expressions" checkbox is selected

  • Hit "Replace All"

Alternative Find and Replace dialog

  • Now you should have all footnotes anchors surrounded by square brackets

image description

  • to remove the superscript style, edit the "Footnote Anchor" style and set the Position to "Normal" in the Position tab.

image description

Here is a simple test document which also has the footnote paragraph at the end, also featuring square brackets: C:\fakepath\footnotes_brackets_test.odt

Still a workaround... but at least gets the job done. Hope this helps.