Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

This is a contentious matter. There are a pair of old bugs AOO#56160 / FDO#50063 relating to this matter. It is really a terminology issue though. The problem is the name of the required Function:

  • Hyperlink = edit a hyperlink.
  • Insert Hyperlink = insert a new hyperlink.

You are probably using the first one, when what you require is the second entry.

click to hide/show revision 2
correct repetitive grammar

This is a contentious matter. There are a pair of old bugs AOO#56160 / FDO#50063 relating to this matter. this. It is really a terminology issue though. The problem is the name of the required Function:

  • Hyperlink = edit a hyperlink.
  • Insert Hyperlink = insert a new hyperlink.

You are probably using the first one, when what you require is the second entry.

click to hide/show revision 3
include screenshots and test comments

This is a contentious matter. There are a pair of old bugs AOO#56160 / FDO#50063 relating to this. It is really a terminology issue though. The problem is the name of the required Function:

  • Hyperlink = edit a hyperlink.
  • Insert Hyperlink = insert a new hyperlink.

You are probably using the first one, when what you require is the second entry.

EDIT: To clarify what I am doing here I am including screenshots of the Customize dialog for Ubuntu, Win7HP, and MacOS 10.6.8. Assignment of CNTL+SHIFT+G (Ubuntu/Win7) / ⇧⌘G (MacOS 10.6.8) to "Insert > Hyperlink" and CNTL+SHIFT+H (Ubuntu/Win7) / ⇧⌘H (MacOS 10.6.8) to "Insert > Insert Hyperlink" works exactly as expected on all systems. That is, hyperlink insertion allows insertion at the point of the cursor, while highlighting an existing hyperlink and using the "edit hyperlink" shortcut allows editing of that hyperlink. All screenshots and tests performed with LO v4.0.2.2.

It is possible that MacOS 10.8.3 and / or WinXPSP3 experience different behaviour, but that would be a platform-specific issue.

click to hide/show revision 4
improve clarity and included Edit menu option

This is a contentious matter. There are a pair of old bugs AOO#56160 / FDO#50063 relating to this. It is really a terminology issue though. The problem is the name of the required Category and Function: pair:

  • Edit > Hyperlink = insert a new hyperlink (via Hyperlink dialog).
  • Insert > Hyperlink = edit a hyperlink.highlighted hyperlink (via Hyperlink dialog).
  • Insert > Insert Hyperlink = insert a new hyperlink.hyperlink (via Character dialog).

You are probably using the first first second one, when what you require is the second last entry. The first and second entry.entries are conflated in terms of naming vs action.

EDIT: To clarify what I am doing here (with respect to the second and third options) I am including screenshots of the Customize dialog for Ubuntu, Win7HP, and MacOS 10.6.8. Assignment of CNTL+SHIFT+G (Ubuntu/Win7) / ⇧⌘G (MacOS 10.6.8) to "Insert > Hyperlink" and CNTL+SHIFT+H (Ubuntu/Win7) / ⇧⌘H (MacOS 10.6.8) to "Insert > Insert Hyperlink" works exactly as expected (excepting naming/action differences) on all systems. That is, hyperlink insertion Insert > Insert Hyperlink allows insertion at the point of the cursor, while highlighting an existing hyperlink and using the "edit hyperlink" Insert > Hyperlink shortcut allows editing of that hyperlink. All screenshots and tests performed with LO v4.0.2.2.

It is possible that MacOS 10.8.3 and / or WinXPSP3 experience different behaviour, but that would be a platform-specific issue.