Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hello,

You have turned on Enable experimental features in LO Options (Advanced). This has enables the use of Firebird embedded database. This change is still in process. With this enabled, when an existing HSQLDB .odb is opened, the option is given to convert to Firebird embedded.

There is nothing wrong with the data and it is not a bug. To stop the message, turn off experimental feature:

Windows/Linux:

Tools->Options then LibreOffice->Advanced

Mac:

LibreOffice -> Preferences then LibreOffice->Advanced

Hello,

You have turned on Enable experimental features in LO Options (Advanced). This has enables the use of Firebird embedded database. This change is still in process. With this enabled, when an existing HSQLDB .odb is opened, the option is given to convert to Firebird embedded.

There is nothing wrong with the data and it is not a bug. To stop the message, turn off experimental feature:

Windows/Linux:

Tools->Options then LibreOffice->Advanced

Mac:

LibreOffice -> Preferences then LibreOffice->Advanced

The error you are getting during conversion could be caused by a variety of things. Only a copy of your .odb can give a clue as to the actual conversion problem.

Hello,

You have turned on Enable experimental features in LO Options (Advanced). This has enables the use of Firebird embedded database. This change is still in process. With this enabled, when an existing HSQLDB .odb is opened, the option is given to convert to Firebird embedded.

There is nothing wrong with the data and it is not a bug. To stop the message, turn off experimental feature:

Windows/Linux:

Tools->Options then LibreOffice->Advanced

Mac:

LibreOffice -> Preferences then LibreOffice->Advanced

The error you are getting during conversion could be caused by a variety of things. Only a copy of your .odb can give a clue as to the actual conversion problem.

Hello,

You have turned on Enable experimental features in LO Options (Advanced). This has enables the use of Firebird embedded database. This change is still in process. With this enabled, when an existing HSQLDB .odb is opened, the option is given to convert to Firebird embedded.

There is nothing wrong with the data and it is not a bug. To stop the message, turn off experimental feature:

Windows/Linux:

Tools->Options then LibreOffice->Advanced

Mac:

LibreOffice -> Preferences then LibreOffice->Advanced

The error you are getting during conversion could be caused by a variety of things. Only a copy of your .odb can give a clue as to the actual conversion problem.

Edit 2018-10-01:

@dshimer I have removed the sample from your question. Data may be a bit confidential/personal.

The error is because of the table name. The space is causing the error. You may want to check/file bug report on this.

Was able to convert by doing the following (should always have a backup copy):

  • In original .odb renamed table from Job Data to JobData - no space.

    • Closed .odb & re-opened

    • Selected Tables section & answered Yes to convert - completed

    • Saved .odb. Firebird embedded requires more saving than the HSQLDB did.

    • Copied JobData table - right mouse click & select copy

    • Pasted table and for name (in dialog presented) changed name to Job Data

You need to be aware of a couple of items. The field types were converted from Text[VARCHAR_IGNORECASE] TO Text[VARCHAR] as the former is not a type in Firebird. You may also need to modify other items. For some items to be aware of, see my answer in this post -> Firebird Migration Expectations

If you have other questions but not specifically regarding this error, please feel free to ask but specify as a new question. Makes it easier for others to find.