Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

My goodness, the update link in the original question appears to point to several issues and solutions, any one of which may have been the cause of this problem. The central issues appears to be CUPS timing out and resetting the printer to a "Generic" option. The final solution appears to have been a CUPS update. Here is my TLDR summary for others:

  • Bug fdo#50784 points out LO/CUPS time-out issue.
  • Bug LP#1020048 is raised to track the issue for Ubuntu.
  • Workaround / solution is suggested in fdo#50784 and taken up by OP. "I fixed it setting "TimeOut 7200" in the /etc/cups/cupsd.conf on the print server.
  • Resolution of fdo#50784 is disputed (which seems fair enough as it is a hack workaround) but bug is closed as the OP closed it.
  • Bug fdo#56344 is raised to address same issue. This bug is still unconfirmed.
  • In comment #33 of LP#1020048 an alternative workaround is suggested: switch LO to use the system Print dialog (Tools > Options... > General > Print dialogs > uncheck Use LibreOffice dialogs. The OP of the question here appears to be using system dialogs anyway.
  • In comment #34 of LP#1020048 it is announced that CUPS v1.6.2 is released and this timeout issue with LO appears to have been specifically addressed.
click to hide/show revision 2
add note about fdo#56344 temporary patch

My goodness, the update link in the original question appears to point to several issues and solutions, any one of which may have been the cause of this problem. The central issues appears to be CUPS timing out and resetting the printer to a "Generic" option. The final solution appears to have been a CUPS update. Here is my TLDR summary for others:

  • Bug fdo#50784 points out LO/CUPS time-out issue.
  • Bug LP#1020048 is raised to track the issue for Ubuntu.
  • Workaround / solution is suggested in fdo#50784 and taken up by OP. "I fixed it setting "TimeOut 7200" in the /etc/cups/cupsd.conf on the print server.
  • Resolution of fdo#50784 is disputed (which seems fair enough as it is a hack workaround) but bug is closed as the OP closed it.
  • Bug fdo#56344 is raised to address same issue. This bug is still unconfirmed.unconfirmed. A temporary patch was offered to fix the issue, but not merged into master.
  • In comment #33 of LP#1020048 an alternative workaround is suggested: switch LO to use the system Print dialog (Tools > Options... > General > Print dialogs > uncheck Use LibreOffice dialogs. The OP of the question here appears to be using system dialogs anyway.
  • In comment #34 of LP#1020048 it is announced that CUPS v1.6.2 is released and this timeout issue with LO appears to have been specifically addressed.

My goodness, the update link in the original question appears to point to several issues and solutions, any one of which may have been the cause of this problem. The central issues appears to be CUPS timing out and resetting the printer to a "Generic" option. The final solution appears to have been a CUPS update. Here is my TLDR summary for others:

  • Bug fdo#50784 points out LO/CUPS time-out issue.
  • Bug LP#1020048 is raised to track the issue for Ubuntu.
  • Workaround / solution is suggested in fdo#50784 and taken up by OP. "I fixed it setting "TimeOut 7200" in the /etc/cups/cupsd.conf on the print server.server."
  • Resolution of fdo#50784 is disputed (which seems fair enough as it is a hack workaround) but bug is closed as the OP closed it.
  • Bug fdo#56344 is raised to address same issue. This bug is still unconfirmed. A temporary patch was offered to fix the issue, but not merged into master.
  • In comment #33 of LP#1020048 an alternative workaround is suggested: switch LO to use the system Print dialog (Tools > Options... > General > Print dialogs > uncheck Use LibreOffice dialogs. ). The OP of the question here appears to be using system dialogs anyway.
  • In comment #34 of LP#1020048 it is announced that CUPS v1.6.2 is released and this timeout issue with LO appears to have been specifically addressed.