Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I had this kind of problems. For example, in addition to random (frequent) crashes, clicking on Tools > Macros > Run macro... would reliably crash LibreOffice, every time.

In my case, the problem was related to Java. Go to Tools > Options... > LibreOffice > Java and select the correct JRE (it has to be a 32 bit JRE6 or JRE7, even on a 64bit OS).

How did I found out?

  • Deleting %AppData%\LibreOffice did not solve the problem for me
  • Reinstalling LibreOffice 3.5 did not solve the problem
  • Uninstalling LibreOffice 3.4 and installing 3.4 did not solve the problem.
  • Uninstalling LibreOffice and installing OpenOffice 3.5 did not solve the problem
  • Uninstalling Java worked (Well, sort of. Of course I couldn't use macros, or any programs using in Java)
  • Installing a 32 bit JRE7 did not solve the problem.
  • Installing a 64 bit JRE7 did not solve the problem.
  • Unchecking "Use a Java runtime environment" did not solve the problem (as long as I had a JRE installed, it would crash)
  • Selecting the correct JRE (32 bit JRE6 or 32 bit JRE7) worked

I had this kind of problems. For example, in addition to random (frequent) crashes, clicking on Tools > Macros > Run macro... would reliably crash LibreOffice, every time.

In my case, the problem was related to Java. Go to Tools > Options... > LibreOffice > Java and select the correct JRE (it has to be a 32 bit JRE6 or JRE7, even on a 64bit OS).

How did I found out?

  • Deleting %AppData%\LibreOffice did not solve the problem for me
  • Reinstalling LibreOffice 3.5 did not solve the problem
  • Uninstalling LibreOffice 3.4 3.5 and installing 3.4 did not solve the problem.
  • Uninstalling LibreOffice and installing OpenOffice 3.5 did not solve the problem
  • Uninstalling Java worked (Well, sort of. Of course I couldn't use macros, or any programs using in Java)
  • Installing a 32 bit JRE7 did not solve the problem.
  • Installing a 64 bit JRE7 did not solve the problem.
  • Unchecking "Use a Java runtime environment" did not solve the problem (as long as I had a JRE installed, it would crash)
  • Selecting the correct JRE (32 bit JRE6 or 32 bit JRE7) worked