Ask Your Question

Revision history [back]

The link opens a popup that can't be closed that directs you to download version 5; minimum version number listed is 4.5.

Page linked does not give the option of downloading LibreOffice 4.3.5. I can't believe that between August 22, 2015 when this question was supposedly answered and September 12, 2015 that that version disappeared.

Info from "System Requirements" link on that page:

Apple - Mac OS X

"The software and hardware prerequisites for installing on a Apple Mac OS X computer are as follows:

Mac OS X 10.8 (Mountain Lion) or higher;
Intel processor;
512 Mb RAM;
Up to 800 Mb available hard disk space;
1024x768 graphic device with 256 colors (higher resolution recommended)."

I believe the answer previously given was absolutely wrong.

:(