Ask Your Question

Revision history [back]

'locale -a' gives you the options available on your system, not what your current locale is. Run the bare command if you want to see what options are currently set for your user:-

:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=en_GB.UTF-8
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

('locale -a' gives the same (wrong syntax) output on my system as you showed; above settings are correct syntax)

Now check that your user's LO setup matches your locale:

  • (menu):ToolsOptionsLanguage SettingsLanguages

The last item is purely for the sake of sanity & should not affect PDF export. If your system is setup for UTF-8 & your font contains all the glyphs for the chars that you are using then there should be zero problems (LO is utf8 by default).

If this helps then please tick the answer (✔)
...and/or show you like it with an uptick ()