Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

A correction: paper orientation choices on my default printer are also grayed out.

Prior users have suggested toggling "Use only paper size from printer preferences" (as opposed to paper orientation) but this did correct the problem for me.

A correction: paper orientation choices on my default printer are also grayed out.

Prior users have suggested toggling "Use only paper size from printer preferences" (as opposed to paper orientation) but this did correct the problem for me.

And now, somewhat later:

By exhaustive trial and error, I've got it working although I haven't solved the reason it went bad it the first place.

Here's what worked for me:

I'm using Ubuntu 16.04 LTS and my label printer is a Brother QL-500. Far as I know, all Brother label printers use the same driver (available at http://www.diku.dk/~panic/P-touch/).

In Ubuntu System Settings > Printers > Brother-QL-500 > Printer Options Uncheck "Concatenate Pages" or your label will not fully advance after printing.

In LibreOfficeWriter, I used Ctrl-P to bring up the print dialogue. Select the label printer. Click "options" tab. Check "Use only paper size from printer preferences". Click "General" tab > Properties button and the Portrait/Landscape option should be re-enabled.

However, instead of printing what's in the upper left corner of the page, which is where I'd placed the label text, it now prints the middle of the page. So I moved my label text down about 23 lines and tabbed over. (I don't know why the change occurred. I'm sure there're some settings in LibreOffice printing defaults that I can fool with but I haven't found them yet. I'm working on this.) And, behold!, the labels print.

Admittedly a bit of a pain in the rear. Next time I buy a label printer I'll be careful to shop for one with full Ubuntu compatibility, if such a one exists.