Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I'm getting something very similar.

Create with LO Calc 5.1.5.2.

Save As Microsoft Excel 2007-2013 XML (*.xlxs).

Transfer to another machine via email.

Update in Excel on an Office 365 system.

Close, saving changes.

Transfer back to first machine via email (.xlxs file).

Open with Calc gets a big white block which covers cells a1:m50. Cut has no effect. Resizing creates a second, third, etc. block which can be cut, but the first block remains.

Open with Excel (15.0.4859.1000) [MSO (15.0.4859.1000) 64-bit, Part of Microsoft Office Professional Plus 2013 Trial] - everything is fine.

Delete all comments - eight cells between a3 and a48.

Close, saving changes.

Open with Calc - everything is fine, apart from the lack of comments.

Happens every time.

I haven't tested sending an unamended version back from Excel yet. I will do so over the weekend and post back if it makes a difference.

I'm getting something very similar.

Create with LO Calc 5.1.5.2.

Save As Microsoft Excel 2007-2013 XML (*.xlxs).

Transfer to another machine via email.

Update in Excel on an Office 365 system.

Close, saving changes.

Transfer back to first machine via email (.xlxs file).

Open with Calc gets a big white block which covers cells a1:m50. Cut has no effect. Resizing creates a second, third, etc. block which can be cut, but the first block remains.

Open with Excel (15.0.4859.1000) [MSO (15.0.4859.1000) 64-bit, Part of Microsoft Office Professional Plus 2013 Trial] - everything is fine.

Delete all comments - eight cells between a3 and a48.

Close, saving changes.

Open with Calc - everything is fine, apart from the lack of comments.

Happens every time.

I haven't tested sending an unamended version back from Excel yet. I will do so over the weekend and post back if it makes a difference.

Update 1: Played about on LO machine following info in https://ask.libreoffice.org/en/question/19176/infinite-white-boxes/ and https://www.youtube.com/watch?v=-h3XTtY4wwg

Got rid of dubious objects via Excel 2013 trial version.

Played about over weekend with changes, saves and transfers.

LO .xlxs version works OK in Office 365 Excel.

All manner of test changes in 365 Excel work OK - although had to remove protection at one stage to see multiple sheets and be able to resize sheet window.

365 Excel shows no objects to delete - so that may be a bit of a red herring.

Transfer saved files back to first machine via email (.xlxs file) after each test change.

Open with Calc gets a big white block again for all transferred files. LO shows no drawing objects in Navigator.

Open with Excel 2013 trial version - everything is fine.

Simple Close in Excel changes nothing BUT Save As Excel Workbook (.xlxs) does.

Open with Calc - everything is fine.

Opened Excel 2013 .xlxs version in Calc - Saved As .ods as master version.

In future will make all changes in LO master version then Save As .xlxs and transfer to Office 365 machine. LO to 365 Excel always works OK.

I don't know whether the problem is with Excel 365 and/or Excel 2013 and/or Calc. But I've got a workaround procedure that I can use when my Excel 2013 trial expires.

I'll try removing all of the comments from the Excel 365 version and send it back to LO to confirm whether this will get rid of the white blocks. If so it will make maintaining the spreadsheet a little easier. I'll post back when I've tested it.

I'm getting something very similar.

Create with LO Calc 5.1.5.2.

Save As Microsoft Excel 2007-2013 XML (*.xlxs).

Transfer to another machine via email.

Update in Excel on an Office 365 system.

Close, saving changes.

Transfer back to first machine via email (.xlxs file).

Open with Calc gets a big white block which covers cells a1:m50. Cut has no effect. Resizing creates a second, third, etc. block which can be cut, but the first block remains.

Open with Excel (15.0.4859.1000) [MSO (15.0.4859.1000) 64-bit, Part of Microsoft Office Professional Plus 2013 Trial] - everything is fine.

Delete all comments - eight cells between a3 and a48.

Close, saving changes.

Open with Calc - everything is fine, apart from the lack of comments.

Happens every time.

I haven't tested sending an unamended version back from Excel yet. I will do so over the weekend and post back if it makes a difference.

Update 1: Played about on LO machine following info in https://ask.libreoffice.org/en/question/19176/infinite-white-boxes/ and https://www.youtube.com/watch?v=-h3XTtY4wwg

Got rid of dubious objects via Excel 2013 trial version.

Played about over weekend with changes, saves and transfers.

LO .xlxs version works OK in Office 365 Excel.

All manner of test changes in 365 Excel work OK - although had to remove protection at one stage to see multiple sheets and be able to resize sheet window.

365 Excel shows no objects to delete - so that may be a bit of a red herring.

Transfer saved files back to first machine via email (.xlxs file) after each test change.

Open with Calc gets a big white block again for all transferred files. LO shows no drawing objects in Navigator.

Open with Excel 2013 trial version - everything is fine.

Simple Close in Excel changes nothing BUT Save As Excel Workbook (.xlxs) does.

Open with Calc - everything is fine.

Opened Excel 2013 .xlxs version in Calc - Saved As .ods as master version.

In future will make all changes in LO master version then Save As .xlxs and transfer to Office 365 machine. LO to 365 Excel always works OK.

I don't know whether the problem is with Excel 365 and/or Excel 2013 and/or Calc. But I've got a workaround procedure that I can use when my Excel 2013 trial expires.

I'll try removing all of the comments from the Excel 365 version and send it back to LO to confirm whether this will get rid of the white blocks. If so it will make maintaining the spreadsheet a little easier. I'll post back when I've tested it.

Update: 2 I sent the Office 365 spreadsheet back to LO (Calc 5.2.7.2) via email. The only comments in it were in the second worksheet. Sent two versions, one with and one without comments. Made no difference - white block in second worksheet. So I'll just carry on using the workaround. I can email myself details of required changes without sending the spreadsheet.

Another thing I noticed, the Excel Save As option that fixes it is 'Excel Workbook (.xlxs)'. The Zimbra Desktop 7.3.0 GA (build 13060) download file type is 'Microsoft Excel Worksheet'. Neither of these options exist in Calc so it's theoretically possible that Zimbra is corrupting the .xlxs in some way that affects Calc but not Excel.

As I'm not sufficiently interested to investigate any further I'll just carry on using Calc to generate .ods masters and emailing .xlxs derivatives to the Office 365 machine.