Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

You cannot add custom icons, if your setting in Tools > Options > LibreOffice View is automatic. So do this:

  1. Prepare an icon image in size 16x16 and one in size 24x24. Use png image in 24-bit, that is without alpha-channel. I'm not sure whether 32-bit will work too.
  2. Use Tools > Customize and add the command "Text Attributes" to a toolbar. You can get it from the alphabetical list "All categories".
  3. Set all entries to small in section User Interface in Tools > Options > LibreOffice View.
  4. Use Tools > Customize, go to the newly inserted command "Text Attributes" and click on Modify and then on item Change icon. It opens the "Change Icon" dialog.
  5. Click on button Import and import the 16x16 image.
  6. Click on the just imported image and then on OK. Close customize dialog.
  7. Set all entries to large in section User Interface in Tools > Options > LibreOffice View.
  8. Repeat step 4.
  9. Repeat step 5, but now import the 24x24 image.
  10. Repeat step 6.
  11. Set all entries to automatic in section User Interface in Tools > Options > LibreOffice View.
  12. I'm not sure, but you might need to restart LibreOffice.

If you have set your menus to always show icons, you should have an icon in front of "Text..." now. You can disable the command in the toolbar, in case you do not want it there.