Ask Your Question
0

Can't install SMF on LO 5.2.7 [closed]

asked 2017-06-20 16:08:50 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Newbie here. I am trying to install the Stock Market Functions on LibreOffice 5.2.7. I have found the SMF 7.0 version and the SMF 8.6 version. Neither one will install in Calc with the Extension Manager.

Errors:<class 'filenotfounderror'="">: [Errno 2] No such file or directory: 'C:\Users\John\AppData\Roaming\LibreOffice\4\user\uno_packages\cache\uno_packages\lu255082i4xz5.tmp_\SMF%20(1).oxt\smf.py', traceback follows C:\Program Files\LibreOffice 5\program\pythonloader.py:94 in function getModuleFromUrl() [fileHandle = open( filename, encoding='utf_8' )] C:\Program Files\LibreOffice 5\program\pythonloader.py:149 in function writeRegistryInfo() [mod = self.getModuleFromUrl( locationUrl )]

(com.sun.star.uno.RuntimeException) { { Message = "<class 'filenotfounderror'="">: [Errno 2] No such file or directory: 'C:\\Users\\John\\AppData\\Roaming\\LibreOffice\\4\\user\\uno_packages\\cache\\uno_packages\\lu255082i4xz5.tmp_\\SMF%20(1).oxt\\smf.py', traceback follows\X000a C:\Program Files\LibreOffice 5\program\pythonloader.py:94 in function getModuleFromUrl() [fileHandle = open( filename, encoding='utf_8' )]\X000a C:\Program Files\LibreOffice 5\program\pythonloader.py:149 in function writeRegistryInfo() [mod = self.getModuleFromUrl( locationUrl )]\X000a\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by erAck
close date 2018-06-25 18:25:01.159971

2 Answers

Sort by » oldest newest most voted
0

answered 2017-06-21 00:17:18 +0200

johninreno gravatar image

Uninstalled LibreOffice Confirmed Java RE 8 Update 131 Download/Install LO 5.2.7.2 win_64 Download SMF 7.0 from archive Used the Extension Manager from the TOP level of LO to install - SUCCESS!

Loaded yahooexample.ods Error: unknown ul type: https

Found this thread: https://ask.libreoffice.org/en/questi...

Edited yahoo.py to "\\download..." - SUCCESS

edit flag offensive delete link more

Comments

Having had a glance over the changes I recommend to use the fork (current release 0.8.6) instead of the unmaintained original. The Yahoo URI change is included, it also works with LO5.2.7

erAck gravatar imageerAck ( 2017-06-21 13:34:29 +0200 )edit
0

answered 2017-06-20 21:15:09 +0200

erAck gravatar image

I don't know what you tried to install, the latest version is 0.7.0, there is no 8.6 or 0.8.6, and 0.7.0 installs fine for me with LibreOffice 5.2.7, on Linux though. Your file name SMF%20(1).oxt makes me wonder if you tried to download or install it twice. Try to uninstall all incarnations and install 0.7.0 from the extension repository or from GitHub.

edit flag offensive delete link more

Comments

I see that you likely are using the SMF-Extension fork which does have a 0.8.6 release. So, it's always good to give details when asking questions.. ;-)

erAck gravatar imageerAck ( 2017-06-21 13:00:02 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2017-06-20 16:08:50 +0200

Seen: 109 times

Last updated: Jun 21 '17