Ask Your Question
0

LibreOffice Writer randomly restarts outline heading numbering

asked 2017-06-25 16:02:36 +0200

Tefached gravatar image

I'm at my wits end. This is driving me absolutely insane.

I have a document layout set up as follows:

(Heading 1) 1. Part (Heading 2) 1. Week (Heading 3) 1. Day ... (Heading 2) 2. week (Heading 3) 1. day ... And then randomly, it restarts heading 2 to say 1. week instead of 3. as expected. Then also, the days count as 1, 2, 3 and then suddenly 1 again. What in God's name is going on? I did a double take just to make sure I didn't accidentally enable "Restart numbering here" on one of the headings or something. The page numbers are a-okay.

What's going on? I'm REALLY pressed for time and so far Libre Office is proving to be more of a hassle than anything else.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-09-18 18:34:36 +0200

jharvell gravatar image

I had the same problem, and in my case the document was originally imported from Word. I noticed that the Numbering Style for some of my heading paragraphs was WWNum1, but for others it was Outline Numbering. But the ability to change this was disabled. I put my cursor on the paragraph of each numbered heading, right-clicked and selected Paragraph. Then under the tab Outline & Numbering, you can see the Numbering Style.

I found out the way to get the Numbering Style to change to Outline Numbering is to click on the Toggle Numbering Icon in the toolbar twice, turning numbering off, then back on. This is the icon right next to the Toggle Bullets icon. It is the icon you would click if you wanted to make a numbered list. Once you turn it off, then back on, you can see the Numbering Style of the selected paragraph change to Outline Numbering. At this point, the numbering of the headings is consecutive with no more resets.

edit flag offensive delete link more
0

answered 2017-06-25 16:22:00 +0200

RGB-es gravatar image

If you use the tools on Tools → Chapter numbering (outline numbering on older versions), each time a high level changes the lower levels are reset. So you get a scheme

1
1.1
1.2
2
2.1
etc.

To get a continuous numbering for the second level you need to not use the default tool but assign a numbering style to the paragraph used for your second (or third) level. You can do that on the Outline & Numbering tab of the style definition.

edit flag offensive delete link more

Comments

No but that is fine. I want the days (3rd level headings) to reset after each 2nd level heading, in my case, weeks. So I'd like it to go, say, 2. week -> 1st day, 2nd day, etc., 3. week -> 1st day, ...

The problem is that the days and weeks reset BEFORE I insert another 1st or 2nd level heading, so I have something like: week 2 -> day 1, day 2, day 3, day 1; week 3 -> day 1, day 2... week 1 -> day 1, day 2, day 3...

Tefached gravatar imageTefached ( 2017-06-25 16:26:55 +0200 )edit

That's quite strange, indeed. Could you upload a sample file somewhere (erase all personal information first!) so we can see what's going on?

RGB-es gravatar imageRGB-es ( 2017-06-25 16:30:53 +0200 )edit

Yes indeed, give me a moment to just trim the document first.

EDIT: here's the link: https://drive.google.com/file/d/0BwWD...

I manually numbered the days (dan in Croatian) so they're in the order I originally wanted them to be, but you can still see my issue with the numbering of the weeks (tjedan). The weeks go 1, 2 and then 1 again.

Tefached gravatar imageTefached ( 2017-06-25 16:32:23 +0200 )edit

The problem seems to start on the third paragraph of page 12: if you change the second paragraph to Heading 2 paragraph style the numbering works, but if you change the third paragraph into Heading 2 the numbering is restarted to 1. I've never seen something like that! The only strange thing I can see on the document is that it has a lot of manual formatting on it. Seems a document imported from Word (follow on next comment because of the stupid comment limit)

RGB-es gravatar imageRGB-es ( 2017-06-25 17:15:55 +0200 )edit

The only advice I can give to you is to copy the content and paste it as unformatted text on a new document, recreating the format by using the correct styles. It seems to me that on the import something got badly screwed with the styles definition: there are almost 50 spurious numbering styles and some strange paragraph styles too that should not be there plus a lot of manual formatting. I think it is better to start anew on a clean file, sorry.

RGB-es gravatar imageRGB-es ( 2017-06-25 17:22:35 +0200 )edit

Yeah you're right, I did have to import this document from Word. I'm doing a diary of my internship since I'm in college, and the professor insists that we import his template and continue on off of it. Splendid.

Thanks for your help. I'll keep on hauling in this thing and then I'll try to salvage as much as I can.

Tefached gravatar imageTefached ( 2017-06-25 17:23:18 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-25 16:02:36 +0200

Seen: 1,181 times

Last updated: Sep 18 '17