Ask Your Question
0

Libre office writer is really slow

asked 2017-07-13 11:16:37 +0200

dorijan gravatar image

I am writing some documentation that has about ~40 pages, 80images plus few tables and and diagrams. The whole *.odt file size is under 32MB. But the response went from slow to unmanageable. Even scrolling takes a lot of time. Adding text is slow, adding images or saving stops the program for several minutes(sometimes even more) and process manager shows it "Not responding" while doing so.

I have tried modifying memory settings in Tools>options, tried it on several computers(2 of them had Intel i7, 8GB RAM and SSD) and I have updated LibreOffice to latest version without any effect.

Same file opened in MS Word without a problem, smooth scrolling "real-time" editing etc.

Current Version: 5.3.4.2 (x64) Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; Locale: sl-SI (sl_SI); Calc: group

edit retag flag offensive close merge delete

Comments

What Font is the document using? Is it using Liberation Sans or another Liberation font? I've noticed this on Windows as well. Office uses different default fonts, so as long as they're on the system they will display, avoiding the issue. Had to stop using the software to make sure those fonts were not on system.

iAnonGuy gravatar imageiAnonGuy ( 2017-07-16 11:07:40 +0200 )edit

7 Answers

Sort by » oldest newest most voted
1

answered 2017-11-17 01:43:48 +0200

Manipot gravatar image

For me, disabling the OPENGL worked.

Uncheck Tools/Options/Libre Office/View/Use OpenGL for all rendering

edit flag offensive delete link more

Comments

This worked. It's not really fast, but faster than having OpenGL rendering turned on. I'm sorry Manipot for not upvoting. I just registered the account and you need five points to be able to upvote.

Yellow Labrador gravatar imageYellow Labrador ( 2017-12-02 01:12:23 +0200 )edit

Thanks for your answer, it worked!

Jimmykid gravatar imageJimmykid ( 2018-10-02 18:32:54 +0200 )edit
1

answered 2018-09-18 23:40:11 +0200

rtlewis1 gravatar image

updated 2018-09-18 23:49:39 +0200

To address one of the prevalent issues, here... Since LO 5, I have invariably had trouble with dragging and dropping multi-lines of text within the same document - it would just hang before reaching the target. Today, I discovered that doing this makes it function perfectly again: go to

Tools > Options > Libreoffice Writer > View

and uncheck 'smooth scroll'

It fixes that issue entirely. For the first time in three years, drag & drop works correctly; and I believe the scrolling is now 'smoother' as well. Go figure...

edit flag offensive delete link more
0

answered 2017-08-06 21:25:43 +0200

Fenton gravatar image

I've had the same problem. But it also happened with V 5.2.4.2.

edit flag offensive delete link more
0

answered 2017-08-03 23:31:08 +0200

Just-a-user gravatar image

This sounds similar to what I have documented here. I've seen various work arounds posted, but none have worked for me.

edit flag offensive delete link more
0

answered 2017-07-13 14:48:48 +0200

TheoB gravatar image

updated 2017-07-13 14:49:47 +0200

Same problem but running CentOS 7. If I scroll my document the display of the pages lags by seconds. I have not seen minutes delay but it's unworkable.

Version: 5.3.4.2 Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 CPU Threads: 8; OS Version: Linux 3.10; UI Render: default; VCL: gtk2; Layout Engine: new; Locale: en-US (C); Calc: group

The previous version was OK:

Version: 5.2.4.2 Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0 CPU Threads: 8; OS Version: Linux 3.10; UI Render: default; VCL: gtk2; Locale: en-US (C); Calc: group

So my workaround is to stay with 5.2.4.2.

edit flag offensive delete link more
0

answered 2017-11-17 23:07:28 +0200

This worked for me. If you do a custom install instead of the typical try uninstalling then reinstall using the typical option. That may clear it up. If not everything i did was uninstalled x64 custom install; installed x86 typical install; uninstalled; installed x64 typical. Was like night and day in performance. Seems either something doesn't get installed or the ui is looking for something in the languages i had unchecked for a leaner install.

edit flag offensive delete link more

Comments

I guess that you simply moved to newer version in the process, which gave you the huge performance gain due to fixes included.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-18 09:50:31 +0200 )edit

No. Had issue on latest version also. I was doing custom install and removing non-English(US) dictionaries and UI languages. I uninstalled thinking maybe it was x64 version only, and installed x86 with typical option and all performance issues went away. Scrolling is now good and I don't have to wait 2 seconds any more for submenus to appear after selecting an item on the menu bar. I uninstalled x86 and re-installed x64 using typical and it is still good. I had this issue for quite few ver now.

DamianA gravatar imageDamianA ( 2017-11-21 20:02:46 +0200 )edit
0

answered 2018-07-19 14:05:33 +0200

desgua gravatar image

Going to Tools > Options > Libreoffice Writer > View and disablying "smooth scroll" made Libreoffice runs much faster for me.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-13 11:16:37 +0200

Seen: 7,135 times

Last updated: Sep 18