Ask Your Question
1

Unity integration in LibreOffice 4.0 doesn't work [closed]

asked 2013-02-08 05:19:22 +0100

Mishich gravatar image

updated 2015-08-28 10:22:28 +0100

Alex Kemp gravatar image

I have install LibreOffice 4.0 in Ubuntu 12.10. It should look like this, but menu not integrated with unity menu on my Ubuntu. my screenshot

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-24 02:14:53.807207

3 Answers

Sort by » oldest newest most voted
0

answered 2013-02-25 20:05:33 +0100

qubit gravatar image

updated 2013-02-26 15:51:02 +0100

@Mishich, @Justin Solms,

Update 3: I just updated the LO 4.0 Release Notes to indicate that Unity integration is available via the official Ubuntu repositories. Only the following Ubuntu/LibreOffice combinations are currently supported:

  • Ubuntu 12.10 + LO 3.6
  • Ubuntu 13.04 + LO 4.0 (will be released in April, but you can test it now)

Update 2:

Bug is filed as fdo#61461 - Ubuntu Unity menu integration advertised in 4.0 release notes, but not present in official builds - UNCONFIRMED

I'm moving the information about PPAs to that bug report, as I think we'll get more people to pay attention to a bug report than a Question on the Ask site.

Please test the PPAs, especially the 4.0 builds, and post an update to Bugzilla re: whether unity menu integration works for you. I don't want to have to scratch that feature from the 4.0 Release Notes, and I'd much prefer to post an addendum pointing users to a PPA.

Update: There are several different Ubuntu repositories (including PPAs). Here are some notes on which packages are available right now:

[moved to bugzilla]

edit flag offensive delete link more
0

answered 2013-02-08 06:24:33 +0100

qubit gravatar image

updated 2013-02-08 07:50:36 +0100

It sounds like this type of integration should be provided via the distro. As Canonical has not yet added LO 4.0.0.3 support in any of its current releases, official integration might need to wait until 13.04 (as mentioned below).

The Release Notes imply that Unity integration is available at release time, but there's obviously an issue in getting that support running. I think the best hope for Ubuntu users is that someone may provide 4.0.0.3 via a PPA, and may include appropriate Unity integration via that delivery channel.


Notes:

In this thread, someone mentions that the integration won't work until 13.04:

Discussion on the LO User list:

I can't seem to find a particular bug for this filed in LO's bug tracker, but there may be one there already (I'll ping the QA team).

edit flag offensive delete link more

Comments

launcher items are not problem. question was about unity menu integration.

Mishich gravatar imageMishich ( 2013-02-08 06:47:12 +0100 )edit

Ah, okay @Mishich. Just saw that -- running on a couple of hours of sleep.

qubit gravatar imagequbit ( 2013-02-08 07:34:46 +0100 )edit
qubit gravatar imagequbit ( 2013-02-21 21:02:10 +0100 )edit
0

answered 2013-02-08 06:01:04 +0100

I have the same problem. OMG Ubuntu site had a news splash that LO4 was ready and that menu bar integration was ready, carried a pic of it too just as in the post above mine. So I uninstalled LO3 and downloaded LO4 and no menu bar integration.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-02-08 05:19:22 +0100

Seen: 2,558 times

Last updated: Feb 26 '13