Ask Your Question
1

unwanted footnote space in docx documents [closed]

asked 2013-02-20 10:29:34 +0200

giorgio gravatar image

updated 2015-11-01 20:03:26 +0200

Alex Kemp gravatar image

I have opened a docx document with libreoffice 4, under OSX 10, and the document appears with an enormous space for footnotes in each page, also where no footnote exists. The effect is that a document of about 100 pages appears as having more than 20 thousands pages. The document opened correctly with the previous version of libreoffice in another mac computer with a earlier OSX version. In the display window that appears next the document name in Finder the document displays correctly without unneeded footnote spaces.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-01 20:03:51.292869

1 Answer

Sort by » oldest newest most voted
1

answered 2013-05-23 12:31:21 +0200

oweng gravatar image

You do not specify your particular MacOS version (other than "10"), LO version, or any details about the styles and formatting in use in the document. It sounds as though the particular document in question is using some unusual styles or other settings that the LO DOCX filter is not handling well. I can't reproduce the problem here using LO v4.0.3.3 (on Ubuntu and MacOS 10.6.8) and MS Word 2012 (on MacOS 10.6.8).

Possible related bugs are fdo#39378, which although marked as a duplicate of fdo#39205, does contain a couple of MS Word 2007/2008 DOCX files. These two bugs indicate that there is a couple of problems with the DOCX file format (as saved or opened by LO):

  • An additional blank line between footnotes (this now appears to be resolved).
  • A leading TAB prior between the footnote identifier and footnote text.

Here is an example bundle of files (ZIP containing one DOCX and three PDFs - please rename file from ODT to ZIP) created in LO v4.0.3.3. a_1_LOv4033.pdf is what the document initially appears like. a_2_LOv4033.pdf is what the document appears like after being re-opened by LO. a_2_MacOS_W2012.pdf is what the document appears like after open in Word 2012 for Mac. Word 2012 has no problem, while LO v4.0.3.3 introduces the leading TABs mentioned.

Using the example files available in fdo#39378, here is a bundle of files (ZIP containing four PDFs - please rename file from ODT to ZIP) created in LO v4.0.3.3 or MS Word 2012, all under MacOS. Only the first page of each example DOCX is converted to PDF. The superscript format of the footnote identifiers is not preserved (indicating another possible bug), but otherwise there are no additional blank lines or TABs.

edit flag offensive delete link more

Comments

1

It looks like this is still (again?) an issue in LibO 4.2.3.3: fdo#76968 + possibly related fdo#75242 - I've added a comment in former. Any idea how to get rid of the extra space manually? I can't figure it out, and I've spent too long trying. Thanks!

David gravatar imageDavid ( 2014-05-06 13:04:18 +0200 )edit

Question Tools

Stats

Asked: 2013-02-20 10:29:34 +0200

Seen: 901 times

Last updated: May 23 '13