Ask Your Question
0

Why do I not have the UK English spellchecker

asked 2017-08-28 23:07:21 +0200

bigpighodges gravatar image

Had v5.3.5 and couldn't get a UK English spellcheck. The language box was blank and would not accept the English GB option. Upgraded to v 5.4 and problem still there

edit retag flag offensive close merge delete

Comments

You didn't mention your OS - and that matters. For Windows, the installer contains all languages and their spellcheckers, but they aren't selected for installation by default. To add them, you need to re-run the installation (e.g., using the downloaded installer, or Windows' Add/Remove programs' Modify feature) and select required components.

Mike Kaganski gravatar imageMike Kaganski ( 2017-08-29 08:39:03 +0200 )edit

To add them, you need to re-run the installation

It is overkill if you only need a spell checker.

gabix gravatar imagegabix ( 2017-08-29 13:32:07 +0200 )edit

:) really? Of course, it's much more overkill to do to Add/remove programs and double-click on LibreOffice line then check components to add, then to search for a package on Internet, think if this will work with your program, download, and then to the same double-click and walk through the same installation process...

Mike Kaganski gravatar imageMike Kaganski ( 2017-08-29 13:45:16 +0200 )edit

OS is Win 10 prof 64bit. The 5.3.5 version when installed was the 64bit version (is this where things started to go wrong?). The current Lib Office is v5.4 with GB help pack. So a reinstall HAS been done but to no effect. The spell checker comes up with "None" in the language box and will not accepy English GB when clicked on!

bigpighodges gravatar imagebigpighodges ( 2017-08-29 15:40:12 +0200 )edit

I didn't mean a reinstall. I meant that you need to check that required components (GB spellchecker) are selected in the installer. If they are, then there's a problem indeed. Helppack doesn't matter.

Mike Kaganski gravatar imageMike Kaganski ( 2017-08-29 15:44:10 +0200 )edit

Yes the English language is set for installation under dictionaries, and under additional interface languages both English GB and English USA are set to install. BUT after running yet another reinstall with these settings checked as correct the spell check comes up with "None" in the language box. Trying to select English UK from the drop down box containing "[None]" does not help.

bigpighodges gravatar imagebigpighodges ( 2017-08-29 20:56:47 +0200 )edit

Also tried removing and reinstalling v5.4 - no improvement! I think I'll regress to 5.2.7

bigpighodges gravatar imagebigpighodges ( 2017-08-30 11:15:48 +0200 )edit

Reverted to 5.2.7 but the problem remains. Is there some registry info which is not being updated correctly? This seems to have happened since I tried installing the 64bit version. How do I clear the problem?

bigpighodges gravatar imagebigpighodges ( 2017-08-30 11:24:32 +0200 )edit

You may try to reset your LO user profile. I suppose the problem isn't related to version or bitness, just somehow corrupted profile.

I use 64-bit version exclusively since 5.0, without issues.

Mike Kaganski gravatar imageMike Kaganski ( 2017-08-30 11:38:14 +0200 )edit

Thanks - resetting the user profile worked. Safe mode worked OK so I reset and all OK. I suspect the problem may have been generated when I added some word to the user dictionary. Another effect was that the font I was using was not rendered correctly wrt character and line spacing. All OK after the profile reset. Thanks for the help!

bigpighodges gravatar imagebigpighodges ( 2017-08-30 13:32:59 +0200 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2017-08-29 07:35:02 +0200

ajlittoz gravatar image

By default, LO comes out-of-the-box with a minimal language pack, i.e. US English only. To localize it to any language, install one or more language packs. The same holds true for the English variants. The English language pack contains variants for UK English as well as for a dozen others (CA, ZA, ...).

See your distro package manager. For Fedora, the name is libreoffice-langpack-en.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
0

answered 2017-08-28 23:27:08 +0200

librebel gravatar image

Hello @bigpighodges,

This extension includes the Dictionary, Hyphenation, and Thesaurus for English (UK) : https://www.weeklywhinge.com/files/en...

Source page: https://www.weeklywhinge.com/?p=69


image description

edit flag offensive delete link more

Comments

It looks that this extension is no longer developed.

gabix gravatar imagegabix ( 2017-08-29 13:39:51 +0200 )edit
0

answered 2017-08-29 13:40:38 +0200

gabix gravatar image

Look here.

edit flag offensive delete link more
0

answered 2017-08-31 09:25:21 +0200

bigpighodges gravatar image

User profile was somehow corrupted ... many thanks to Mike Kaganski .. see above. I suspect the user dictionary may have become corrupted during an update with new words .. but can't be sure. Starting in Safe mode removed the problem and indicated an issue with the user profile. Thanks to all for your suggestions and Mike Kaganski for the way out of the problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-08-28 23:07:21 +0200

Seen: 2,363 times

Last updated: Aug 31 '17