Ask Your Question
0

Calc formatting percents with decimals bugged?

asked 2017-09-13 03:08:24 +0200

Spaz102 gravatar image

updated 2017-09-13 16:10:12 +0200

I want 0.05 to show as "5%" I want 0.055 to show as "5.5%" I would expect the custom formatting of "#.#%" to work, but I get "5.%" and "5.5%".

It seems the decimal placeholder is treating the percent symbol as a valid digit, and thus displaying a period when it shouldn't

edit retag flag offensive close merge delete

Comments

With Russian locale, which uses , as decimal separator, #,#% gives expected result (5% and 5,5% for 0.05 and 0.055 resp.); with English (USA) locale, #.#% works (5% and 5.5%). I am testing with Version: 5.4.1.2 (x64) Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527 CPU threads: 4; OS: Windows 6.19; UI render: default; Locale: ru-RU (ru_RU); Calc: group

You don't give your system and version info.

Mike Kaganski gravatar imageMike Kaganski ( 2017-09-13 16:35:49 +0200 )edit

Excellent, there's hope! I'm on 4.4, and I have no excuse or idea why updating wasn't the first thing I tried

Spaz102 gravatar imageSpaz102 ( 2017-09-15 04:03:25 +0200 )edit

Yes, I reproduce your problem with Version: 4.4.0.3 Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7 Locale: ru_RU

Mike Kaganski gravatar imageMike Kaganski ( 2017-09-15 06:14:45 +0200 )edit

4.4 is way outdated..

erAck gravatar imageerAck ( 2017-09-16 16:21:26 +0200 )edit

1 Answer

Sort by » oldest newest most voted
-1

answered 2017-09-13 04:56:33 +0200

librebel gravatar image

Hello @Spaz102,

try if format code "0.#%" works.

edit flag offensive delete link more

Comments

Unfortunately, it still puts a decimal right before the percent sign: "5.%"

Spaz102 gravatar imageSpaz102 ( 2017-09-13 16:09:46 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-09-13 03:08:24 +0200

Seen: 25 times

Last updated: Sep 13