Ask Your Question
0

caption language

asked 2017-09-15 09:17:40 +0200

wdj gravatar image

I have the same problem as this person:

https://ask.libreoffice.org/en/questi...

As the mentionedp ost is 4 years old and no working solution has been brought up I'd liek to know how I can change caption language to dutch. I've set every possible language setting EXCEPT user interfaceto dutch as there is no option to do so (only ennglish usa englush uk etc).

I wouldn't mind changing the dafault caption text manualy but I'd rather not have to change it every time I input a caption as I do now as I have to add more than 100 captions. I'm going to have to add I'm new to LibreOffice and really only using it because it's the only suitable package this company has, I don't have enough experience and no one here seems to know or remeber how to change it.

edit retag flag offensive close merge delete

Comments

Please what version have installed?, if it a development version, then only English for UI, but a launched version allow to select those selected at installation. When install select 'custom' and select what dictionaries and what UI languages you like.

m.a.riosv gravatar imagem.a.riosv ( 2017-09-15 14:14:57 +0200 )edit

You can change the language for new documents independent from the UI language in Tools > Options > Language Settings > Languages. Besides that, you can make a document template with the desired language settings. For an existing document, you can change the paragraph style "Default Style" to change all styles, or change the paragraph style "Caption" only for captions. Language is in tab "Font".

Regina gravatar imageRegina ( 2017-09-15 21:30:03 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-09-15 23:20:50 +0200

Jim K gravatar image

updated 2017-09-15 23:25:20 +0200

Table captions can be changed like any other text, by going to Edit -> Find & Replace. Search for "Table" and replace with "Tabel".

Either find and replace one at a time, in case there are some occurrences of "Table" that should not be replaced, or else simply do Replace All.

Any new tables can be captioned automatically with "Tabel" by going to Insert -> Caption and pressing the Auto... button. Check LibreOffice Writer Table.

edit flag offensive delete link more

Comments

Replace all should be used sparingly. I would rather insert everything from scratch.

Kruno gravatar imageKruno ( 2017-09-16 07:38:12 +0200 )edit
0

answered 2017-09-16 07:43:32 +0200

Kruno gravatar image

updated 2017-09-16 16:16:59 +0200

I've set every possible language setting EXCEPT user interface to dutch as there is no option to do so

Download Dutch user interface and install it. For the rest, see that link you posted.

Translated user interface is what's holding caption filed titles (presets).

Don't know if this will change already inserted captions from English to Dutch.

edit flag offensive delete link more

Comments

1

Nope, once inserted captions become "ordinary" text. They are not fields. You change them with usual find & replace.

ajlittoz gravatar imageajlittoz ( 2017-09-16 13:41:45 +0200 )edit
0

answered 2017-09-16 08:23:13 +0200

ajlittoz gravatar image

updated 2017-09-16 13:57:48 +0200

LO Writer can handle multi-language documents without objecting, i.e. without being confused by spell-checking or other utilities, provided the current language is indicated to LOW.

Language is an attribute of paragraph style which you find in the Fonts tab of the style dialog.

In your case, if this document is written in Dutch, set Default Style language to Dutch and it will propagate to all other styles. You do it like that:

  1. Show the styles navigator with Format>Styles & Formatting or F11
  2. Right-click on Default Style and choose Modify...
  3. Got ot Font tab
  4. In the Language drop-down menu, select Dutch (BE and NL variants are available)
  5. Click OK

Note: If the language name is not tagged with a blue tick+ABC, the language pack is not installed. It only means that spell-checking will not be done.

If you intend to use Dutch for all your documents, define Dutch as the default:

  1. Open the general settings dialog with Tools>Options
  2. Select Language Settings>Settings
  3. Choose your default language in Default languages for documents/Western
  4. Push OK
  5. Close and restart LO Writer to make sure

EDIT:

There is a way to change the caption to anything you like, but it is only a workaround because the caption feature does not take into account the currently selected writing language around the point of insertion.

The first time you insert a caption (Insert>Caption...), change the Category in the dialog: put the cursor in the text box and replace the word here, e.g. tekst or illustratie and proceed as usual.

Next time you insert a caption, the previous category is preselected.

Even better, your custom category persists between sessions. You'll find it in the drop-down menu associated with the Category text box.

There's however a limitation to this workaround: the category can only be a single word. No way to use spaces in the name. There's no free meal! You can circumvent this limitation by activating the auto-insertion feature, but you must plan ahead your document to avoid chaos and later tedious manual patches:

  1. In the caption dialog, push the Auto... button
  2. Click on the desired object types at left
  3. Select then each one in its turn and adjust the settings for this type; in particular, you can customize the category and any sentence (= sequence of words) can be used.

When a new checked object (frame, picture, drawing, diagram are the most interesting) is inserted, the customised caption is automatically added. If you do not like automatic insertion, do it once, then disable it. The category with spaces is now entered in the drop-down menu and can later be selected at will. Of course, remove the unnecessary caption.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

I think he men English caption field title (table) when what he needs is Dutch caption filed titles (tafel). At least that's what's talked about in that link posted in original question. Language in font tab is reflecting locale setting, but caption field title is pulled (I think) from translated user interface.

Kruno gravatar imageKruno ( 2017-09-16 11:52:25 +0200 )edit

Tempted to file enhancement request as caption filed title should be pulled from locale file, not translated UI. Many have English UI but different locale settings. Having part of text in foreign language usually mean example or insert (appendix) but you actually write in language that you set locale to. Caption title filed should be translated in respective localization files and pulled from there the same way date formats are.

Kruno gravatar imageKruno ( 2017-09-16 12:00:51 +0200 )edit

Apologies, I didn't understand immediately the point. I tried playing with the language attribute, but it is too late. It is applied after the various captions are retrieved and they stick with the UI. However there's a workaround; see my edit.

ajlittoz gravatar imageajlittoz ( 2017-09-16 13:26:17 +0200 )edit

Only the predefined caption 'Categories' are localized (along the UI-language, I suppose). You are not bound tio use these cateories. simply enter categories of you own choice in the 'Insert Caption' dialog, first line below 'Properties'. Whatever you enter there will be a new category then, and will be offered as a choice during further work on the document.

Lupp gravatar imageLupp ( 2017-09-16 14:32:05 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-09-15 09:17:40 +0200

Seen: 640 times

Last updated: Sep 16 '17