Ask Your Question
1

turning off word count in scroll bar?

asked 2017-10-23 16:59:27 +0100

bdpollack gravatar image

Greetings, all. I've got a huge journal document I've accumulated over the years, and every time I upgrade to the next libreoffice version, I go through a little ritual. I first open that document (now 1800+ pages) in Writer, and the moment I start to make an edit, I play the game of 'is this document about to crash' because the slightest change causes a cascade of word-counting in the status bar, below.

So, invariably, for the past few years, I have compromised and turned off the display of the status bar. But this, of course, prevents me from using the status bar's other features. Is there instead a way to make the status bar exclude certain elements? For an 1800 page document of very dense text, the count-as-you-go word count feature is a hindrance, not a help, and I'd love to be rid of it without sacrificing the rest of the status bar's information and functionality.

-BDP

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2017-10-23 19:51:27 +0100

Regina gravatar image

The content of the statusbar is described in the file statusbar.xml. You find this file in the installation folder of LibreOffice in share/config/soffice.cfg/modules/swriter/statusbar. You can edit the file directly or you copy that file and insert it at the similar place in your user folder. Remember to make a backup, before editing.

For editing you can use any editor, that preserves line ending and character encoding. Find the line <statusbar:statusbaritem xlink:href=".uno:StateWordCount" statusbar:align="left" statusbar:autosize="true"/> and remove it.

But I'm not sure whether this will solve your problem, because word count is done anyway.

I find that in large files the option Word Completion from the AutoCorrect options takes some resources and have disabled it.

edit flag offensive delete link more

Comments

Since turning off the display of the status bar itself resolves my issue every time, I think it's more in the fact that with an 1800 page file, it wants to recount all the words and display the running count inclusive as it is still counting every time I open the file or do anything inside it. And that is what appears to be slowing me down. Thanks, I'll try your suggestion with the XML edit.

bdpollack gravatar imagebdpollack ( 2017-10-23 19:56:28 +0100 )edit

Works like a charm. A great, big, beautiful charm. Thank you so very much.

bdpollack gravatar imagebdpollack ( 2017-10-24 14:48:00 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-23 16:59:27 +0100

Seen: 123 times

Last updated: Oct 23 '17