Ask Your Question
0

Able to Specify Quote Type in a Style?

asked 2017-10-27 00:56:40 +0200

bsmither gravatar image

Creating a 'Code' style in Styles and Formatting, based off Preformatted Text.

I set the font to be DejaVu Sans Mono (as opposed to Liberation Mono), but this still uses smart/curly quotes as allowed by the font having this character.

I wish to have AutoCorrect disabled when using the 'Code' style, and have it enabled otherwise. Probably Spell Checking as well.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-10-27 08:23:13 +0200

ajlittoz gravatar image

In your 'Code' style, Font tab, set Language to [None] from the drop-down menu. This will disable spell checking and all locale-specific text transformation (among which typographic replacement for quotes).

You can do the same for character style Source Text which is used to style code excerpts in ordinary paragraphs.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-27 00:56:40 +0200

Seen: 119 times

Last updated: Oct 27 '17