Ask Your Question
0

How to add text above the first endnote?

asked 2017-11-17 18:11:47 +0100

JPmiaou gravatar image

This ought to be simple, but isn't: above the first endnote, I need to enter a heading ("Notes") and a short paragraph of text. If I try to click at the beginning of the first note and hit "enter", it does Bad Things to the first endnote, and I can't figure out how to fix them with anything other than Undo. Clicking at the end of the previous page and using the down or right arrows doesn't do anything, so I can't address the problem from that end. I can't find anything that looks even remotely useful in the page setup or style settings.

What am I doing wrong?

More detail:

Starting point:
a Lastname, Firstname, title, blah blah
b Othername, blah blah blah

Click before the L (it will not let me "get at" the "a" at all) and hit Enter, and I get:
a
a Lastname, ...
b Othername, ...

Both of the "a"s are linked to the body text endnote anchor. If I click in the first paragraph and change the style from "endnote" to "heading1" (or whatever), I get:
a
Lastname, ...
b Othername, ...

I can't move the anchor around at all, because I can't select it, so whatever I try to do with that first paragraph, it stays part of that first endnote.

How do I get a paragraph ABOVE that first endnote?

edit retag flag offensive close merge delete

Comments

The answers so far imply that it is not possible in LO to structurally achieve what I need; instead, two different hacks have been offered. Can this really be the case? Chicago Manual of Style, for example, suggests that the logical place for a global note or a short list of abbreviations is at the beginning of the Notes section, but it sounds like that is impossible to do when using LO's notes function. Why? What am I missing?

JPmiaou gravatar imageJPmiaou ( 2017-11-19 06:47:23 +0100 )edit

I've attached a sample file to my answer below (it is imposible to attach a file to a comment).

Does it look like what you try to achieve?

ajlittoz gravatar imageajlittoz ( 2017-11-19 08:03:54 +0100 )edit

That's basically the appearance I want (minus the extra space between the paragraph and the endnote), but it's not the right underlying structure, because the endnote area is a separate unit from the heading and global notes that are supposed to go with it. Also, in my 60-page document, the spacing between the text and the notes is glitchy, and if I save it as docx, I have to re-do the whole insert section thing every time I open the file. (It also arbitrarily re-names and redefines my styles.)

JPmiaou gravatar imageJPmiaou ( 2017-11-19 19:47:49 +0100 )edit

Style renaming is inherent to docx conversion. Format conversion is plagued with the differences between design concepts in the applications. Roundtrips are not idempotent: you don't retrieve the original file. Avoid conversions as much as you can (use them with caution only for the final print-ready copy, but you'll still get glitches).

Not the right underlying structure: could you elaborate a bit? Be aware that I'm not a native English speaker, try then to be simple yet accurate.

ajlittoz gravatar imageajlittoz ( 2017-11-19 20:56:02 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2017-11-17 18:23:55 +0100

Platterbaff gravatar image

The only way I have ever found is to create a header for the endnote page and put your heading and paragraph in there.

This seems to be an intractable problem. Some people, like me, want endnotes immediately after the document text, but LO seems to insist on insists on a new page with nothing in the text area except endnotes. One of those things we must live with I guess.

edit flag offensive delete link more

Comments

How do you get around the global nature of headers? I don't want "Notes" at the top of every page.

JPmiaou gravatar imageJPmiaou ( 2017-11-19 06:11:03 +0100 )edit

Modifying the Endnote page style seems to change only the page with that style. It leaves headers on other pages alone. I don't know what would happen if you have so many endnotes that the system creates more endnote pages. Try it and see. I never have that many notes. .You might also want to fiddle with the header's format to get everything looking right (eg take out any separator line)

Platterbaff gravatar imagePlatterbaff ( 2017-11-19 13:56:07 +0100 )edit

Accessing the page styles is hard, but I think I've figured it out. I have two pages of endnotes currently, for which turning off "same on first page" is enough; I don't know what would happen if I had three pages.

JPmiaou gravatar imageJPmiaou ( 2017-11-19 19:30:53 +0100 )edit
1

answered 2017-11-17 21:11:07 +0100

RGB-es gravatar image

Select your document content → Insert Section → on Footnotes/Endnotes tab → Endnotes, then select "Collect at the end of the section".

Now you'll be able to add any text before the endnotes, use a page break to any page style, etc.

You can use this to get endnotes by chapter, for example.

edit flag offensive delete link more

Comments

A better way. Thanks.

Platterbaff gravatar imagePlatterbaff ( 2017-11-17 21:55:14 +0100 )edit

That's how it _is_ set up: the endnotes start their own page at the end of the document. (I would love to get rid of the separate page, too, but that's a separate question, I think.) I don't want a page break; I want to label the effing page. And HOW do I "add any text before the endnotes"??? That's my problem: I can't. It steadfastly and resolutely stays part of the first endnote. And I _can't_ "select my document content" -- it'll only let me select one endnote at a time.

JPmiaou gravatar imageJPmiaou ( 2017-11-18 00:07:37 +0100 )edit

I tried putting the cursor at the beginning of the first endnote (or as close as I can get, which is before the L in my example). Then I did the Insert menu - Section - Footnote/Endnote - collect at end box. Guess what I got? EXACTLY THE SAME THING. Character-for-character exactly the same behavior as I describe in my question.

JPmiaou gravatar imageJPmiaou ( 2017-11-18 00:27:53 +0100 )edit

To apply @RGB-es' solution, put the cursor anywhere in your text (not endnotes) and Ctrl+A, then insert section, etc.

It is a very good trick +1

ajlittoz gravatar imageajlittoz ( 2017-11-18 08:17:10 +0100 )edit

This hack only allows me to put text on the same page as the endnotes, close to them but still separate in the underlying structure. (Elsewhere in the document, I need the separator line between text and footnotes, so the other answer's hack of using the page header may be better suited to my purposes.) Does LO really absolutely enforce such a senseless separation between document and endnotes?

JPmiaou gravatar imageJPmiaou ( 2017-11-18 14:46:40 +0100 )edit

And a new problem: why is it adding so much space above the endnote? I can't get my text any closer than about an inch above it. I've set everything I can find, such as the separation betweeen footnotes and text, to zero, but it does no good. Where is this setting hidden, and how is it (mis)labeled?

JPmiaou gravatar imageJPmiaou ( 2017-11-18 15:03:35 +0100 )edit

I can't reproduce your problems. In my test, added test is immediately followed by endnotes, once separator line is removed., no "so much space", in fact none at all. I must add some manually.

Please edit your question to describe step by step what you precisely did. Since your karma is 11, you can also attach a sample file with the problem.

ajlittoz gravatar imageajlittoz ( 2017-11-18 16:58:32 +0100 )edit

The extra space above the endnotes appears to be an off-and-on glitch or bug in styles or their on-screen rendering: updating the styles sometimes fixes it. Other times it takes closing and re-opening the file.

JPmiaou gravatar imageJPmiaou ( 2017-11-19 05:57:31 +0100 )edit
0

answered 2017-11-17 22:03:55 +0100

ajlittoz gravatar image

updated 2017-11-19 08:02:47 +0100

Addition to @RGB-es' answer:

To get rid of the horizontal segment between text in the section (presumably a heading and possibly an introductory paragraph), go to Format->Page, Footnotes tab and set Separator Line, Length to 0%

EDIT 2017-11-19

Sample file attached: NoteSample.odt

edit flag offensive delete link more

Comments

Huh? This has absolutely nothing to do with my question. The default is for a quarter-length line between text and footnotes, yes, but I'm not talking about footnotes.

JPmiaou gravatar imageJPmiaou ( 2017-11-18 00:10:07 +0100 )edit

The separator line appeared when I experimented the suggestion. I re-checked to see if I made a mistake and I confirm a separator line replaces the page break between text and endnotes. Consequently, there is a need to wipe out the separator.

ajlittoz gravatar imageajlittoz ( 2017-11-18 08:14:14 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-11-17 18:11:47 +0100

Seen: 146 times

Last updated: Nov 19 '17