Ask Your Question
1

[SOLVED]Why are there less pages and random gray boxes in my document? [closed]

asked 2013-03-07 03:58:14 +0200

Eternal gravatar image

updated 2013-06-27 20:51:37 +0200

manj_k gravatar image

Hello there.

As the title explains, I'm a bit confounded by this. I jumped on the opensource wagon recently because, honestly, ms word is way overpriced. As I've seen so far, ms word doesn't do anything differently either. Enough about my conversion testimony anyway. Down to the source of my issue.

I'm a bit of an aspiring author and(while working on ms word) I wrote my manuscript. My computer, however, was past the point of repair so, after months of putting it off, I bought a new computer. This is when I decided to convert to opensource and leave ms word behind. I opened up my manuscript in libreoffice and saw a very large decrease in pages from what I remembered(my document is 773 pages in ms word as opposed to the 573 on libreoffice). I was a bit scared, as you may have imagined(I've worked on this manuscript for two years) but after revising the document, everything seems to be in order. I'm wondering why this is. Is it because of the formatting? If so, is there a way I could possibly return it to its original state?

Also, there are strange small grey boxes littered throughout the document after most sentences. Is there a way to get rid of them? The page numbers also seem to have been highlighted with a grey color so my assumption is that rather than gray boxes there are random highlighted gray spaces.

Here's a screenshot: Grey Boxes.png

If it's of any further help, after every sentence, I double spaced as protocol for a manuscript.

Thank you for taking your time to read this and I'll be waiting for a reply.

Eternal

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-02 03:21:04.516089

4 Answers

Sort by » oldest newest most voted
0

answered 2013-03-07 06:02:27 +0200

qubit gravatar image

Hi @Eternal,

I opened up my manuscript in libreoffice and saw a very large decrease in pages from what I remembered...773 pages in ms word [vs.] 573 on libreoffice...Is it because of the formatting?

It's quite possible that various differences contributed to this page discrepancy:

  • Font - It's possible that LibreOffice is displaying your document using a different (but perhaps similar) font than MS-Office
  • Margins
  • Line spacing

If so, is there a way I could possibly return it to its original state?

It's possible that you could try to match all of the things listed above, tweak spacing, character kerning, etc.. and get pretty close to the same layout metrics. Unless you have some specific need to match the old document so closely, I'd just let the text reflow as it will.

Also, there are strange small grey boxes littered throughout the document after most sentences. Is there a way to get rid of them? The page numbers also seem to have been highlighted with a grey color so my assumption is that rather than gray boxes there are random highlighted gray spaces.

I believe that the page numbers appear with a grey background to indicate that they are an automatically-calculated/data field.

If it's of any further help, after every sentence, I double spaced as protocol for a manuscript.

Ahh.. that looks like it corresponds with the grey boxes. Perhaps the grammar checker or some other tool is trying to tell you to stick with single-spaces? (I just tried using double spaces between sentences on LO 4.0.0.3, and no such grey boxes appeared for me)

Regarding the double-spacing, Wikipedia notes:

Much modern literature on typography says that double spacing is not desirable, but other sources indicate that it could be used on a typewriter or with a monospaced font. The majority of style guides opt for a single space after terminal punctuation for final and published work, with a few permitting double spacing in draft manuscripts and for specific circumstances based on personal preference.

It looks like you're using a variable-width font, so I'd suggest that you try a single space. Either way, you can probably search-and-replace those grey squares to either the empty-string (to go with a single space), or to a regular space character (to go with double-spacing).

edit flag offensive delete link more

Comments

After you mentioned the "search and replace" option, I copied a single grey box and pasted it into the "find" tool. It seems like it was a character in of its own because after pressing enter to search for the next match(and a few matches after that) they were all gray boxes. I used find and replace, using the same character as earlier in the "find" section and using a single space(the one generated by pressing the spacebar) in the "replace" section, clicked replaced all and had a favorable-

Eternal gravatar imageEternal ( 2013-03-07 06:43:22 +0200 )edit

result. Thank you for your help in regards to that matter. As for the formatting, I'll tackle that problem later. I found the tidbit from wikipedia interesting because I was led to believe that the double spacing after each sentence was commonplace. I followed the advice shared by a published author and I was sure that was the only way to go. Guess I was wrong.(It's also strange that these comments have a character limit. I understand thankyou's are short things, but elaborate replies notsomuch)

Eternal gravatar imageEternal ( 2013-03-07 06:44:12 +0200 )edit

@Eternal, Two notes:

  1. Well the limit just got bumped up from 300 chars -> 500, so you have a lot more room to talk than you used to :P
  2. Looks like you have some double-posting going on in your comments. There's a bit of a delay with the site (yeah, another bug :P), so please only press the "add comment" button or hit the ENTER key once, then wait for the comment to be posted.
qubit gravatar imagequbit ( 2013-03-07 06:54:00 +0200 )edit

66% bump and here I am complaining. xD Well thank you for that. I actually didn't know I could just press enter to send my message. I was just trying to enter a paragraph break and it seemed like it wasn't working. Anywho, a night's a night. Hopefully I'll be able to fall into a nice groove with my new software.

Eternal gravatar imageEternal ( 2013-03-07 07:10:55 +0200 )edit

@qubit

I'm not sure if you receive a notification with these comments, but on the chance that you do, I'd like to thank you again. Regarding the problem with the length of my document, it seems the problem was mostly due to the font I was using. My new computer didn't have "Dark Courier" installed so after I installed it and re-opened my document, everything seemed like it was back in order. Thanks again!

Eternal

Eternal gravatar imageEternal ( 2013-03-08 06:06:33 +0200 )edit

@Eternal -- thanks for the kind words! If my answer solved your problem, please mark it as correct so it will be resolved. Thanks!

(every time @qubit is mentioned in a post, I get an email update, so feel free to ping me that way :-)

qubit gravatar imagequbit ( 2013-03-08 06:15:39 +0200 )edit

@qubit Will do! Thanks for all the prompt help. : D

Eternal gravatar imageEternal ( 2013-03-08 06:23:15 +0200 )edit

@qubit Actually, another quick question. How do I mark it as correct? I only see the close/edit/flag as inappropriate options.

Eternal gravatar imageEternal ( 2013-03-08 06:26:10 +0200 )edit
qubit gravatar imagequbit ( 2013-03-08 06:50:15 +0200 )edit
1

answered 2013-03-07 09:27:37 +0200

Mark12547 gravatar image

The gray vertical bars in the edit screen indicate non-break space. (You can manually create them in LibreOffice with Ctl+Shift+SpaceBar (or Insert | Formatting Mark | Non-breaking Space).

Apparently Word will take two spaces and convert one of them to a non-break space to make sure that the two spaces at the end of the sentence is preserved. (This is also an HTML trick to make sure that the rendering of the page preserves the two spaces because all regular spaces get collapsed into one space when a HTML page renders on the screen.)

So, when the Word doc was converted to Writer, the converting routine errs on the side of caution and preserves the non-break space.

When the document is actually printed, there will be spaces, not the grey boxes. (You can see this in Page Preview (either by clicking on the "Page preview" icon, or Ctrl+Shift+O, or File | Page Preview).

When you type in new text, you can just hit the SpaceBar twice and Writer will know you want a double-space without having to sneak in a non-breaking space, so new stuff you type will look normal (no gray boxes).

The page numbers are in a grey box to indicate that those are the display values of fields in the document, in this case, the Page Number field. When previewed or printed, you will see just the number, not the gray box holding the number.

edit flag offensive delete link more

Comments

1

@Eternal"Is there a way to get rid of them?"

Press "Ctrl+F8". (See also → Highlighted black spaces?)

manj_k gravatar imagemanj_k ( 2013-03-07 10:43:34 +0200 )edit
1

Thanks! This fixed the gray box problem right away.

Eternal gravatar imageEternal ( 2013-03-08 02:37:27 +0200 )edit
1

answered 2013-03-07 07:38:19 +0200

ROSt52 gravatar image

For a document with even around 100 pages I would always work with a master document. Using a master document will make single files smaller and easier to handle.

Have a look into Help or the documentation on the web.

edit flag offensive delete link more
1

answered 2013-06-11 11:07:07 +0200

cipricus gravatar image

To just avoid seeing the grey spaces (a very common occurrence when opening in LO or OO a document coming from MSO), go to View/Field Shadings

image description

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-07 03:58:14 +0200

Seen: 7,643 times

Last updated: Jun 11 '13