Ask Your Question

Reset language back to ENglish _ from cesky

asked 2017-12-17 16:42:33 +0100

julyjim gravatar image

I set my app to Czech ( Cesky) and now I cannot reset set it back to English ( jazyk - anglictina ) or "back to origninal language ". What am I missing ?

edit retag flag offensive close merge delete


How did you do that? With Tools->Options?

ajlittoz gravatar imageajlittoz ( 2017-12-18 07:57:00 +0100 )edit

No I used Tools -> Language->Czech -> Full text

There is no apply etc. it just changes the tool bar on the fly

Now I have Nastoje -> Jazyk -> English -> Pro cely text and tool bar stays in Czech / cestine

I am about to download another LibreOffice to fix this , but I need to alternate between English and Czech. I hope I can have two copies of LibreOffice in Ubuntu

julyjim gravatar imagejulyjim ( 2017-12-18 15:57:13 +0100 )edit

2 Answers

Sort by » oldest newest most voted

answered 2017-12-19 01:31:38 +0100

julyjim gravatar image

This is not MY answer to resolve the issue . Just comments which would not fit into "add comments" box .

You can, of course, address both problems with "direct formatting", i.e. define the language with Tools->Language->For Selection/Paragraph, but sooner or later you'll get lost when That IS THE problem - I CANNOT !

Great, whatever you call it - my interface in now in Czech AND there are no equivalent of English "options" as you present it, rather complicated way, the only option I can see is to revert "language" to " original setting " or change language to English - same way I went from English to Czech. Neither one of these parameters - available in Czech interface menus - do not NOT change the top menu bar back text to English.

I think you are making it more complicated that it is - I actually need to change top menu bar / text back to English. In essence nothing to do with actual language used to write to the application.

Your attempt to "blame" the situation on spell check is , to put it nicely , peculiar. I hope you won't get offended, but you may as well say I need to use Czech option only on weekends. And if my situation is indeed caused by spellcheck - this is a BIG BUG, not just inability to go back to original language EASY.

edit flag offensive delete link more


Tools->Options is the last item in Tools menu.

If you can't recover with a configuration change in Options, backup your user profile somewhere, erase the "system" copy and restart LO. See instructions.

ajlittoz gravatar imageajlittoz ( 2017-12-19 08:13:37 +0100 )edit

Thanks Tools->Options is the last item in Tools menu is the answer to recover from language selection. Little odd menu structure is my last comment - but you were right - it was a user problem - I missed the LAST menu item because...

The minor issue is - why I cannot SELECT English language same way I selected Czech?

And why "return to original language " does not work?

julyjim gravatar imagejulyjim ( 2017-12-19 17:49:17 +0100 )edit

If you can describe a procedure to reproduce systematically this misbehaviour, I (you, as you like) 'll report a bug. I never had it with my localised version.

ajlittoz gravatar imageajlittoz ( 2017-12-19 19:22:16 +0100 )edit

answered 2017-12-18 20:43:35 +0100

ajlittoz gravatar image

From your comment, I think you tackle the problem the wrong way unless you have a very very specific need.

Make a thorough distinction between the language for the UI and the language(s) for the text.

Unless you're an LO documentation contributor (this is the specific need), you operate your LO in your native interface language. Of course, to display screenshots for international audience, it is better to switch the UI to English. But you won't need it every day. The setting is available in Tools->Options, then Language Settings->Languages, section Language of.

Usually one writes in a "principal" language. This "main" language is designated also in Tools->Options, then Language Settings->Languages, sections Default language for documents. This has the effect to "localize" paragraph style Default Style from which all other styles inherit.

Occasionally, you write multi-lingual documents: either full paragraphs are single-language (different from paragraph to paragraph) or multi-language (base paragraph in one language with words or subsentences in a different language).

You can, of course, address both problems with "direct formatting", i.e. define the language with Tools->Language->For Selection/Paragraph, but sooner or later you'll get lost when trying to review your document.

The correct way is to define custom clones of paragraph style Text Body differing only in Font Language. You choose one of such styles when starting a paragraph with a different language. For intra-paragraph words or sub-sentences in a different language, do the same with character styles.

If you are not familiar with LO styles, you're strongly advised to read the manual.

Your question is also related to spellcheck. Search this site with this keyword.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more


**You can, of course, address both problems with "direct formatting", i.e. define the language with Tools->Language->For Selection/Paragraph, but sooner or later you'll get lost when


Strongly recommend to READ the OP before going on wild goose chase showing that you did not grasp the issue and in process blamed this on "user fault".

julyjim gravatar imagejulyjim ( 2017-12-19 01:31:30 +0100 )edit

Yes but there is not enough matter to read. Your intent is missing: do you want to change only the UI or to write mixed-language documents? I opted for the latter because Tools->Language is provided for that, not to change the UI. Then there may be a bug. Which LO version? Which OS?

ajlittoz gravatar imageajlittoz ( 2017-12-19 08:08:09 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2017-12-17 16:42:33 +0100

Seen: 92 times

Last updated: Dec 19 '17