Ask Your Question
0

Captions in different language than user interface

asked 2017-12-19 15:03:43 +0200

_Rahra_ gravatar image

Is it possible to have captions (like "Illustration:") in a different language than the user interface?

I use English as user interface language. But the document I'm working on is in German language. The whole document is set to German, I also tried to set the language for the current document again under Tools->Options->Languages. It doesn't change the captions. The only way is (as far as I could find out) to change the language of the user interface.

Regards, Bernhard

edit retag flag offensive close merge delete

Comments

Well, generally speaking, it's not easily possible to implement. The strings you are talking about are part of translation, and as the translation files are only installed optionally, it's impossible to expect in general case that the files are present for the language chosen as the default for a document (or for new documents), if it's different from UI language (which can only be set if the required files are present).

Mike Kaganski gravatar imageMike Kaganski ( 2017-12-20 10:51:05 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-12-19 15:34:30 +0200

librebel gravatar image

Hello @_Rahra_,

In the Insert Caption dialog, you can type your own word into the Category listbox, i.e. instead of "Illustration" you could type "Bild" or so...

Hope it helps, lib

edit flag offensive delete link more

Comments

Yes thanks, that works but I consider this just as a workaround.

_Rahra_ gravatar image_Rahra_ ( 2017-12-19 15:48:37 +0200 )edit

@_Rahra_: I wouldn't generally call that a workaround. Being able to define own caption groups is a feature anyway.

On the other hand: You complained about the captions not matching the UI language. What's your document language? In my understanding the default captions should match the document language instead of the UI language or the locale setting.

Lupp gravatar imageLupp ( 2017-12-19 16:16:49 +0200 )edit

Yes indeed, that's exactly what I complained about! The captions shall match the document language but not the UI language. But they don't. My UI is English, the document is German (and the document language is set to German in LO as well). Thus, spell checker and everything else works with German language except the captions.

_Rahra_ gravatar image_Rahra_ ( 2017-12-19 16:46:07 +0200 )edit

-1- Sorry. I didn*t read the question thoroughly enough.
-2- Strange. I mostly have the same language configuration as you: UI English (UK), locale English (UK), documents often German (Germany), sometimes different. Nonetheless I never consciously noticed the problem. Obviously I was accustomed to use my own keywords for groups of captions.
-3- I tested with V6.0.0.0beta1 and it also showed the issue.
-4- Will now search for bug reports..

Lupp gravatar imageLupp ( 2017-12-19 17:36:33 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-19 15:03:43 +0200

Seen: 280 times

Last updated: Dec 19 '17