Ask Your Question
0

write doesnt do anything when selecting scanner source

asked 2017-12-20 22:01:34 +0200

Pops gravatar image

updated 2017-12-21 00:28:27 +0200

Hi I've just installed LibreOffice Version: 5.4.4.2 (x64) on a W10 64bit PC, I am trying to scan an image into a document, the problem is when I select "scanner source" nothing happens nor does selecting scan. I have restarted the PC since installing LibreOffice but its made no difference. I also have OpenOffice installed and this function works fine. Regards David

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-12-21 11:11:38 +0200

Pops gravatar image

I read elsewhere on this site that the 32 bit version works OK with scanners so I've uninstalled the Version: 5.4.4.2 (x64) and installed Version: 5.4.4.2 86 (32bit) The scanner function seems fine and at the moment all other options appear to work fine. Fingers crossed the problem with the 64bit version is fixed soon but I'm not holding my breath. There is a Beta 6.0.0 version but theres no evidence this problems been addressed so I haven't tried it. The link for the 86 version is here https://www.libreoffice.org/download/...

edit flag offensive delete link more

Comments

The problem is 64-bit TWAIN drivers. They are often just absent. Look, e.g., here. 32-bit software works with 32-bit drivers; for 64-bit software, relevant drivers are required. Btw, you didn't mention your scanner model.

Mike Kaganski gravatar imageMike Kaganski ( 2017-12-21 11:18:27 +0200 )edit

My scanner is an Epson Perfection V370 I've manually updated the driver to 3.9.2.3 from 3.9.2.1 but its made no difference, the scan function works OK with OpenOffice, I read that the 32 bit LibreOffice version works OK with 64 bit Windows so I've uninstalled Libre 64 bit and installed Libre 86 and it appears the scan function and everything else works fine so far. You may be right about 32bit driver but where do I find a 564 bit version I cant see a specific 64 bit version on Epsons web site

Pops gravatar imagePops ( 2017-12-21 11:31:52 +0200 )edit

So that's of course that. The Epson product support page mentions v3.9.2.4; but it only contains 32-bit TWAIN driver (its 64-bit settings redirect to 32-on-64 support).

Well: a program is simply unable to use different-bitness libraries. And so if your vendor doesn't provide necessary drivers, no version upgrade of LibreOffice would be able to fix that.

Mike Kaganski gravatar imageMike Kaganski ( 2017-12-21 12:15:48 +0200 )edit

Can you explain why the scan with Epson V370 function has and always works OK with OpenOffice

Pops gravatar imagePops ( 2017-12-21 13:21:24 +0200 )edit

Because they had never had, and have not, 64-bit build for Windows.

Mike Kaganski gravatar imageMike Kaganski ( 2017-12-21 13:29:24 +0200 )edit

Thanks for that I now realise why 32bit java has to be installed when using OpenOffice. Am I likely to have any problems using LibreOffice 32bit on a 64bit operating system

Pops gravatar imagePops ( 2017-12-21 13:45:41 +0200 )edit

Well, no problems - unless you have a huge documents likely to hit 32-bit memory limitation; they are rare, but not absent, so there is some probability of that.

Mike Kaganski gravatar imageMike Kaganski ( 2017-12-21 13:55:38 +0200 )edit

Fingers crossed as I have had OpenOffice crash out when working on large file size docs, fortunately LibreOffice has a good built in photo compression so that may save a few issues..

Pops gravatar imagePops ( 2017-12-21 14:00:02 +0200 )edit

I have installed the printer drivers for 64 bits but still the select source is not working but if i use open office it's is fine! LibreOffice should support this function because it is very important for many users like to scan documents directly to to the page!

jrf62music gravatar imagejrf62music ( 2018-06-22 01:23:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-20 22:01:34 +0200

Seen: 718 times

Last updated: Dec 21 '17