Ask Your Question
0

Failed to execute default Web Browser. How to change/restore?

asked 2017-12-31 18:37:57 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

How can I change my default web browser in LibreOffice 5.4.3.2?

LibreOffice Build ID: 5.4.3-4.0; OS: Linux 4.14 (Distro: Arch32) ; UI render: default; VCL: gtk3;

Problem: When I Ctrl-Click a link in my text document, an error message comes up with the following message:

Failed to execute default Web Browser.

Failed to execute child process "firefox" (No such file or directory).

When I do ‘File – Preview in Web Browser’ in LOffice, the document itself opens up in my default web browser Firefox. Apparently LibreOffice somehow -does- know which is my default browser...

In the beginning... The first time using Ctrl-Click to open a link, it asked me which browser is my default browser. I accidently typed in: firefox. Which seemed it was the wrong answer. :-s

My default browser... Firefox-ESR 52.5.3 (32-bit) is my default browser and in Preferences it is marked as being the default browser and it is marked for always doing a check if it is the default browser. I have no other web browsers.

I have searched the internet for many hours to find a solution for changing my default web browser in LibreOffice but couldn’t find a recent working solution for this. Now I can't open any links in the document. :-\ I only found elder solutions that doesn’t work anymore in my recent version of LOffice. The LOffice Help function wasn't very helpful either about this...

What's the trick to fix this problem?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-01-14 20:05:44 +0100

Ms Tickles gravatar image

Yes that's true but I accidentally pressed too soon Enter before putting the %U, so by accident it went only 'firefox". :-s Now I don't know how to restore this because now it only comes with the message "Failed to execute default Web Browser." without an option to change this with the right startup command. Strangely enough Writer does know automatically about using Firefox for doing a "Preview in Webbrowser" but not for opening a link in a document. Since this, Writer also doesn't make links automatically when hitting Enter after placing a link in the document. I can't find any option in Writer to set this up correctly. I can't find any restore trick either for this on the web.

edit flag offensive delete link more
0

answered 2018-01-12 13:28:29 +0100

petermau gravatar image

I think the command should be FIREFOX %U, not a plain FIREFOX. If you view the properties of the FIREFOX startup icon you will see this %U. %U indicates to FIREFOX that there is an associated URL to execute. Otherewise there is no child for it to execute.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-12-31 18:37:57 +0100

Seen: 45 times

Last updated: Jan 14