We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

[Writer] - copy of file - style changes - why? [closed]

asked 2018-01-04 14:14:01 +0200

luk gravatar image

updated 2020-08-11 12:35:37 +0200

Alex Kemp gravatar image


I made a copy of my Writer file. After I open the copy I use ctrl+a to select and delete all content. Then I want to start writing in this file and here is where the problem starts. The 'default' style is changed the text is shown as a link [underlined and blue color].

In the previous file , where the 'default' style works fine , when I type a word a get this: 'example'. In second file, when I type the same word I get word 'example', but seen as a hiperlink with underline and blue color.

If I try to change this by Styles, it won't work, because now Wirter acts as if 'default' style is text like a hiperlink. Other Styles work the same way since they inherit.

After some tries I think that this only happens, when I copy a file that has a link at the begging of the document, so like: 'https://ask.libreoffice.org' , is in the first line, and the rest is a normal text.

To sum up:
Does anyone know, why this happens? How can I change [in a fast way, just by choosing Style] Style in the copy of my file, so that the text will be normal, not hiperlink?

Thanks for help in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-29 09:03:50.009884

3 Answers

Sort by » oldest newest most voted

answered 2018-01-08 09:00:01 +0200

ajlittoz gravatar image

If you suspect some remnant from previous hyperlink, hover over newly inserted text. If a tooltip Ctrl-click to open hyperlink appears, you definitely have an internet link. It can be removed with right-click and choosing Remove Hyperlink. In addition, styling must also be reset.

If there is no hyperlink, a special internal character style may still be in effect. When LO detect an hyperlink, it adds to your styling its own flagging to allow click-connections to the target. This flag cannot be removed with Format>Clear Direct Formatting or Ctrl+M. Instead:

  • select the "polluted" area (or select whole document with Ctrl+A -- it does not matter since you are beginning with a brand new one),
  • open the style side pane with F11,
  • click on the second icon from the left in the toolbar (character style),
  • you might see Internet Link selected but it may be overridden by another style,
  • double click on Default Style

In case Default Style is already selected, double-click first on another style, e.g. Emphasis, then on Default Style to make sure you revert everything to default.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more


Great, it's the perfect solution to my problem. Exactly what I was searching for.
Thank for the help.

luk gravatar imageluk ( 2018-01-09 18:16:18 +0200 )edit

answered 2018-01-04 15:16:18 +0200

floris v gravatar image

If this is your way of starting a new document with predefined formatting, you should really make a template. Start a new document (that ensures that there's nothing left of any text in a document ) , then open the styles list and modify all styles that you want - typically Default and Heading. If you use other styles, modify them as well. Then save the blank document as a template. From then on, you can start a new document based on that template by selecting New - From template.

edit flag offensive delete link more

answered 2018-01-06 19:36:29 +0200

luk gravatar image

First, thanks I haven't thought about that. It is a good idea.

But, this with method I create a new file and must choose where to sign it.

Im interested if there is a way how I can change the style in my second (the copy) Wirter file. It's easier for me to drag and copy a Writer file in Explorer, than to make a new one from Wirter options, where I have then to choose where to save it, and I must then search for the path to the folder where I want it to be saved.

I will try to test your advice, but still it's not the answer I was hoping for.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-01-04 14:14:01 +0200

Seen: 128 times

Last updated: Jan 08 '18