Ask Your Question
0

Styles go outside selection

asked 2018-01-15 19:09:33 +0100

Masterfrog gravatar image

I select a piece of text

I press a Style to apply to it (either from the quickbar or from the Styles and Formatting window).

It applies the style to way more text than I selected for no apparent reason. This obviously shouldn't happen.

How do I remedy this?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2018-01-15 19:40:42 +0100

floris v gravatar image

You probably applied a paragraph style. Paragraph styles affect the entire paragraph, not just selected text. Page styles are even worse.

If that isn't your problem, please give more information, like style name.

edit flag offensive delete link more

Comments

I was trying to apply styles like Title or Heading. If these are paragraph styles that makes even less sense to me, headers and titles do not make up entire paragraphs.

Masterfrog gravatar imageMasterfrog ( 2018-01-15 19:57:03 +0100 )edit

Worse?

Mike Kaganski gravatar imageMike Kaganski ( 2018-01-15 20:11:13 +0100 )edit

@Masterfrog: yes those are paragraph styles; and that makes perfect sense, if you take into account, that technical term "paragraph" means "text between two paragraph breaks (= Enter)". To make a heading, you put an Enter, then type the heading text, then put an Enter again, and then go on with the rest. So, your heading becomes enclosed between two paragraph marks, and so substitute a full paragraph of its own.

Mike Kaganski gravatar imageMike Kaganski ( 2018-01-15 20:14:19 +0100 )edit

@Masterfrog: You may be mixing up the Dutch (or German) "paragraaf", "section" in English, and English "paragraph", which is "alinea" in Dutch.

floris v gravatar imagefloris v ( 2018-01-15 21:08:11 +0100 )edit
0

answered 2018-01-15 20:08:33 +0100

Platterbaff gravatar image

If you apply a new paragraph style it will apply to all the paragraphs that are wholly or partly included in the highlighted text. And a paragraph only ends (as far as LO is concerned) when a paragraph end mark is inserted by pressing the Enter key.

When I come across your problem it is usually because the text includes blank lines which give the appearance of separate paragraphs, while LO will apply the formatting to the following text up to the next paragraph end mark.

Set Writer to display at least some formatting marks including particularly “Paragraph end” “Breaks” and “Non breaking spaces”. To do this open the “Tools” menu and select “Options” > “LibreOffice Writer”>”Formatting Aids” for a list of what you can have displayed. Some people find the marks a bit off-putting but you should soon get used to them.

edit flag offensive delete link more
0

answered 2018-01-15 19:41:23 +0100

Grantler gravatar image

Paragraph style? Character style? There's a difference.

For better understandig view non-printable characters / formatting marks.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-01-15 19:09:33 +0100

Seen: 47 times

Last updated: Jan 15 '18