Ask Your Question
1

File Edit.... toolbar disappeared along with text formatting

asked 2018-01-31 17:43:50 +0200

alun gravatar image

updated 2018-01-31 22:15:21 +0200

Hello I have lost the toolbars . Tried everything to get them back. Grateful for any help. Also autotext seems to be not accepting new entries. Using 5.4 and tried reinstalling newer version. OS is Windows 7image description Thanks for the votes

edit retag flag offensive close merge delete

Comments

You got enough points to upload your screenshot now...

librebel gravatar imagelibrebel ( 2018-01-31 18:07:08 +0200 )edit

Thanks - I have added a screenshot

alun gravatar imagealun ( 2018-01-31 22:15:49 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-01-31 22:26:42 +0200

paul1149 gravatar image

The fact that is survived a new install points to a defective user profile.

If you press Alt does the menu appear? That's a system setting in Windows, often used on laptops.

You can close LO, rename your LO user profile, and then open LO to create a new profile. See if that changes anything.

edit flag offensive delete link more

Comments

Hi thanks for trying to help. Alt button does nothing. I googled how to rename the user profile. It said to restart in safemode which didnt help and it said that therefore the userprofile was not the problem? I found the user folder on my laptop but not sure how to rename. Worried about losing autotexts too - I have a lot. They still woork but new ones cannot be added. causes a fatal error

alun gravatar imagealun ( 2018-01-31 23:13:35 +0200 )edit

I was unaware of that new Safe Mode method. My way of doing it is to rename the folder hierarchy, which is very simple and guaranteed effective. Whatever you do, take a backup of the profile so nothing will be lost in the experimenting.

AutoTexts should be located at .../libreoffice/4/user/autotext/mytexts.bau under your appdata\Roaming hierarchy.

These problems sound like a permissions conflict. Has the user profile been copied over from a different user or machine?

paul1149 gravatar imagepaul1149 ( 2018-02-01 12:39:09 +0200 )edit

Hi. Ive made a back up. I wasn't 100% sure what you meant by 'rename the folder hierarchy'? I tried to rename the 'user' folder to alun, but it says the 'action cannot be completed as the folder is open in another program' Closed everything else down but still the same. btw the user profile hasn't been copied over from another machine. Although this laptop is a refurbished second hand one. Would uninstalling help? I tried to do that before but no response when I clicked uninstall. Thanks again

alun gravatar imagealun ( 2018-02-01 13:50:45 +0200 )edit

I assume that LO's new method of checking the profile is sound. But if you want to double-check (I would), in Windows Explorer go to your user folder, then appdata\roaming\libreoffice. Rename that folder to libreoffice-mine. Do this with LO closed and the quick start closed. You can call up Task Manager by right-clicking the taskbar and kill anything LO. When you reopen LO it will create a new user folder with correct permissions.

paul1149 gravatar imagepaul1149 ( 2018-02-01 14:18:04 +0200 )edit

Hi. Closed all LO applications in task manager. Renamed as described. Opened a file but no menus at all on top now on top now. A sidebar has appeared with styles,properties,page etc In the Roaming folder a new LO folder appears each time I open the propgram.

alun gravatar imagealun ( 2018-02-01 15:39:15 +0200 )edit

Yes, it will create a new folder if none exists. If it's creating multiple folders that is a problem.

To get back to where you were, delete the new folder and return your profile back to its original name.

Is any other program acting up? This may be corruption of the Windows User profile. Once you're back to Square One, you can copy the LO profile to a USB stick, create and log into a new Windows user, paste back the LO profile into its appdata, and retry LO.

paul1149 gravatar imagepaul1149 ( 2018-02-01 17:11:16 +0200 )edit

Hi. In the end I tried reinstalling. It did work this time as I closed down the stuff in task manager that was still running. The toolbars came back which is great. I saved the autotext so I can sort that. However now when I go to open a file it says 'The requested operation requires elevation'. Tried chamnging the permissions but they were mostly OK anyway. And I can open the files with Open office. I will try and find permissions in LO. Any further advice gratefully received.

alun gravatar imagealun ( 2018-02-01 18:40:07 +0200 )edit

OO opens the same docs LO doesn't? That confirms there is a permissions problem, but now it seems to be with the executable rather than the profile. Do the permissions of the LO folder under c:\program files line up with those of other nearby folders? Also check the one at c:\program data, I think it is. If there's a problem, maybe a complete uninstall, and deleting those two folders before reinstalling would be in order.

paul1149 gravatar imagepaul1149 ( 2018-02-01 21:12:33 +0200 )edit

OO opens the files no problem. The permissions of the LO folder are all now Full Control but still get the Elevation message. Previously I did a complete uninstall and got the toolbars back. I can open files that are in the recently opened section, but they appear without toolbars! However double clicking an old file gets the Elevation message. Appreciate your time on this

alun gravatar imagealun ( 2018-02-01 23:13:49 +0200 )edit

It's clearly a permissions issue, the question is where it lies. I would do a chkdsk /f on the C drive to check the file system, which is where permissions are stored. You might need to schedule it for the next boot.

paul1149 gravatar imagepaul1149 ( 2018-02-02 02:21:37 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-01-31 17:43:50 +0200

Seen: 357 times

Last updated: Jan 31 '18