What is preventing installation of LibreOffice 5.4 Help?

asked 2018-02-08 03:00:57 +0200

catbill gravatar image

updated 2018-02-08 15:38:10 +0200

I am trying to install the LibreOffice 5.4 Help pack in my Windows 10 computer. However, when I try to do so, a message says “A newer version of LibreOffice 5.4 Help Pack was found. To install an older version, the newer version needs to be removed first.

It is a perplexing message. Is there really a newer version of the 5.4 Help pack (that is still called “5.4 Help Pack”) other than what we can download from the main download page?

Something I did must have caused this problem. I installed a parallel version of LibreOffice 6.0, but that involved a few downloads of both 5.4 and 6.0. The 6.0 version is installed in the root directory. The 5.4 version is installed in the Program Files folder.

However, I was not able to uninstall some versions that did not appear in the Programs and Features list of the Control Panel. So, I moved those folders to a backup drive.

There must be remnants somewhere. To install the 5.4 Help pack, what files needs to be removed and from where? Any insights would be appreciated.

edit retag flag offensive close merge delete

Comments

It detects help pack for 6.0 installed. The "LibreOffice 5.4" from the message comes from the installing package: it doesn't know which version it has detected, only knows its own name and that the detected one is newer.

You cannot install neither LibreOffice nor its help pack in parallel on a system. However, you can unpack the installer to a directory, and use it there (methods are listed here, mentioning help pack).

Mike Kaganski gravatar imageMike Kaganski ( 2018-02-08 15:47:07 +0200 )edit

Thanks, Mike. Please bear with a few more questions, as I am clearly not a techie.

It sounds like I should uninstall 6.0, then install the 5.4 Help pack, then reinstall 6.0 Is that what you are suggesting?

I used the Separate Install GUI to install 6.0. Unfortunately, I must have overlooked the option for downloading the help installer.

catbill gravatar imagecatbill ( 2018-02-08 18:25:45 +0200 )edit

It would be great if you could attempt to explain the difference between install and unpack. When I try to research online, I mainly get information about moving companies.

Thanks again!

catbill gravatar imagecatbill ( 2018-02-08 18:26:33 +0200 )edit

The methods on the page I referred to above include the msiexec /a ..., which extracts files from the installer into a directory, but does not install them. Installation is not simply unpacking; installer performs much more things, like registering fonts, associating file types, checking for older and newer versions, updating system, etc. So when you simply double-click an MSI, it's being installed; when you use msiexec /a ..., files are simply extracted.

Mike Kaganski gravatar imageMike Kaganski ( 2018-02-08 18:46:30 +0200 )edit

Thanks for the clarification. It wasn’t clear to me that you were talking about extracting files. I thought you were saying that unpacking is somehow an alternative to installing. Reading that again, I think you were saying that a parallel program cannot be directly installed with the installer and that what matters is where the program is installed. Is that correct?

catbill gravatar imagecatbill ( 2018-02-08 20:03:30 +0200 )edit

It sounds like I should uninstall 6.0, then install the 5.4 Help pack, then reinstall 6.0 with its Help pack. Is that what you are suggesting?

catbill gravatar imagecatbill ( 2018-02-08 20:05:08 +0200 )edit

I suppose that you don't need to uninstall LibreOffice 6.0, only its help pack.

Mike Kaganski gravatar imageMike Kaganski ( 2018-02-08 21:06:52 +0200 )edit

OK. I will try that. Thank you!

catbill gravatar imagecatbill ( 2018-02-08 22:13:28 +0200 )edit

I uninstalled 6.0, reinstalled 5.4, then reinstalled 6.0. All is well, with one exception: when the 6.0 Help is open, there is text showing the contents on the left, but no text displayed on the right.
This glitch was present before I uninstalled and reinstalled, but I hoped it would go away after reinstalling. Any thoughts about what might be happening?

catbill gravatar imagecatbill ( 2018-02-09 02:42:57 +0200 )edit

Since this question is a little different from the topic of this post, I created a separate post with screenshot here: https://ask.libreoffice.org/en/questi...

catbill gravatar imagecatbill ( 2018-02-09 03:24:15 +0200 )edit