Ask Your Question
0

odd spacing before hyphen (auto-hyphenation)

asked 2018-02-09 19:31:39 +0100

JReis gravatar image

"Automatically" checked for hyphenation under 'Text Flow' in paragraph style (though I believe this also happens when using the hyphenation dialogue via Tools > Language > Hyphenation. On some lines, there is a space between the final character on the line and the inserted hyphen. This does not happen with every hyphen, please see linked screenshot 4th line from bottom ending in "Numer-. The word Numerals is hyphenated and an odd space separates the 'r' from the hyphen. Debain Stable 9.3 | LibreOffice installed from backports repo. Additional packages 'libreoffice-gtk' & 'hyphen-en-us' installed

image description

Version: 5.4.4.2
Build ID: 1:5.4.4-1~bpo9+1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

note: I believe this is the same issue as described --here-- many years ago and indeed the hyphen abuts text normally in 'Print Preview'

edit retag flag offensive close merge delete

Comments

Not sure if this is the cause: your zoom level seems to be 148% which does not fit easily with rounded font sizes. Check if your problem is a display (font renderer) artefact by setting zoom to congruous values like 50%, 100%, 150% or 200%.

ajlittoz gravatar imageajlittoz ( 2018-02-09 20:12:34 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-02-10 09:45:45 +0100

RGB-es gravatar image

updated 2018-02-10 09:51:00 +0100

I can see the problem with Linux Libertine G, but not with Libertinus Serif

image description

Note that while both are forks of the original Linux Libertine fonts, only the Libertinus project is actively maintained and developed.

Libertinus does not seem to have the !! and !? ligatures, but it have a lot of bug fixes and a ton of OpenType features not present on the original project.

edit flag offensive delete link more

Comments

Excellent information, thanks. I made this template so long ago that it actually uses the Graphite version of Linux Libertine. Switching it over to the OpenType version (changing G to O in each styles) was a 10 minute job and fixed the issue. I'll be sure to take a look at the Libertinus project.

JReis gravatar imageJReis ( 2018-02-12 08:01:55 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-02-09 19:31:39 +0100

Seen: 88 times

Last updated: Feb 10 '18