Ask Your Question
1

Custom Options->Libre Office->Memory settings? [closed]

asked 2018-02-14 02:13:21 +0200

EasyTrieve gravatar image

updated 2018-02-14 04:04:04 +0200

Does anyone have any good suggestions for how to go about choosing settings for memory?

image description

I tried a few different settings for memory, but am not sure how to choose good settings.

The Help for this dialog (snapshot below) is pretty unhelpful I think:

image description


I am having an issue where LO hangs for many seconds at a time, and then resumes, as if it is doing extended garbage collection. Sometimes it even hangs and issues the Force Quit? dialog, lol, to which I say no, and then if I wait awhile it resumes. It does not crash.

I suppose it could also be a bug, but it occurs randomly, except that it's predictable after a few edits. Edit, Edit, Edit, ... hangs for awhile, resumes.

It sure looks like garbage collection running amuck. I've also attached a snap of the CPU activity of my machine as this happens. Curiously it runs CPU1 for awhile, with CPU2 mostly idle, then swaps activity and runs CPU2 while CPU1 is idle, then again and again, never running them both much at the same time.

image description

LO 5.4.4.2 / Linux Debian Stretch 9.3

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by EasyTrieve
close date 2018-02-20 04:42:37.397544

Comments

2

@Mike Kaganski & @librebel, I just found the source of this extreme slowness. My report had 3 grouping levels with 10 accumulation subtotal functions, some with custom functions. The function property Pre evaluation was set by default to Yes on these 10 accumulators. When I set it to No, suddenly the system had 1000x improvement in speed, strangely both in saving my design edits, and in running the reports. It was a real surprise that this could cause both of these slowdowns.

EasyTrieve gravatar imageEasyTrieve ( 2018-03-09 01:21:14 +0200 )edit

This should be the answer to a more specific question - with details where the options are. It would be of great help to many.

Mike Kaganski gravatar imageMike Kaganski ( 2018-03-09 07:41:32 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-02-14 06:50:08 +0200

Mike Kaganski gravatar image

There are no good suggestions about those settings, because they are used for image and OLE object caches. Nothing else.

I have removed the page altogether from 6.0 to stop confusing users about those settings. The settings are available now only in Expert configuration, for those exceptionally rare cases when they are actually useful.

LibreOffice main code doesn't use GC (it is C++, and uses smart pointers that destroy objects immediately after they aren't used anymore). GC is used in Java, of course, but I couldn't imagine a scenario where you'd see LO freezing because of that (well, there are many things existing in the world I cannot imagine :))

The best would be to try to debug the problem, including getting backtrace for those moments when program freezes.

edit flag offensive delete link more

Comments

Thanks Mike. This helps.

EasyTrieve gravatar imageEasyTrieve ( 2018-02-20 04:41:49 +0200 )edit
0

answered 2018-02-14 12:42:38 +0200

librebel gravatar image

Hello @EasyTrieve,

i also get that “Force Quit or Wait” dialog popping up regularly in LibreOffice, especially when i also have Firefox running at that time.

Firefox plus 4 instances of “Web Content” together take up 1400 Mb of memory, while soffice.bin uses only 240 Mb of memory on my system.

In my case, it seems that Firefox is the main culprit, because these symptoms do not occur anymore after i quit Firefox, while continuing with LibreOffice.

Are you perhaps using Firefox too ?

I saw that your “Number of Objects” under “Cache for Inserted Objects” is set to 500 ( mine is set to 15 ). Unless one day you decide to insert 500 OLE Objects into your document, this number could be decreased to free up some memory.

HTH, lib

edit flag offensive delete link more

Comments

1

@librebel, Hi. I also noticed Firefox being a problem, esp. w/ multiple tabs open, but also some tabs are worse than others and run lots of javascript. You can enter about:performance into the url box to have Firefox look for tabs with bloat and be asked if you want to close them.

But unfortunately, at the time of my tests above I didn't even have Firefox open, or anything else, so as to help isolate what was going on.

Thanks!

EasyTrieve gravatar imageEasyTrieve ( 2018-02-20 04:41:20 +0200 )edit

Thanks for the tab about:performance, i tried several ways to decrease FF memory usage through the years, currently migrating 90% of my tabs to addon "OneTab"...

librebel gravatar imagelibrebel ( 2018-02-20 12:53:54 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2018-02-14 02:13:21 +0200

Seen: 2,399 times

Last updated: Feb 14