Ask Your Question
0

Trying to open a .odb file in newest version of Base and get the error SQL Status: HY000

asked 2018-02-17 17:54:10 +0200

olahchar gravatar image

It says I need JRE, but it is installed.

edit retag flag offensive close merge delete

Comments

Running LO 5.4 and JRE Version 8 update 161

olahchar gravatar imageolahchar ( 2018-02-19 03:16:13 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-02-20 23:53:26 +0200

olahchar gravatar image

Installed JDK and I can now access the base .ODB.

edit flag offensive delete link more

Comments

Must be on Mac! Of course you never provided details as asked for. If it was a Mac you should of had this solved with the answer originally given. It was on the first link posted days ago.

Ratslinger gravatar imageRatslinger ( 2018-02-20 23:56:49 +0200 )edit
0

answered 2018-02-17 18:46:07 +0200

Ratslinger gravatar image

updated 2018-02-17 19:33:56 +0200

Hello,

In the future please provide some minimal info in your question such as OS, LO version & in this case the bitwise of LO & JRE (32 or 64).

There is probably a few answers to correct your problem. Either your LO settings are incorrect or you have the wrong JRE/JDK installed. The answer to each is on this post - on firefox and have loaded java 32.

Another possibility is that the .odb is a connection to an Access DB (again a stab in the dark because of lack of info). If that is the case, you have probably changed from 32 to 64 bit LO & the built in connector for Access only works under 32-bit LO. To possibly connect to Access in 64-bit LO use a JDBC connector. See mdb files not loading to base for one possible solution.

If this answers your question please tick the ✔ (upper left area of answer). It helps others to know there was an accepted answer.

edit flag offensive delete link more

Comments

Based upon duplicate question, what type database in .odb are you connecting to - embedded, Access other external? Is the message the same? What is on Tools->Options->Libreoffice->Advanced dialog (settings mentioned in linked answer above)? Is LO 32 or 64 bit? What OS are you using? Second request for some of this info. Can't help if not provided.

Ratslinger gravatar imageRatslinger ( 2018-02-19 21:39:05 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-02-17 17:54:10 +0200

Seen: 289 times

Last updated: Feb 20 '18