Ask Your Question
1

Can't change (list) {decimal} separator

asked 2018-03-13 13:18:41 +0200

Loufas gravatar image

updated 2018-03-13 15:24:14 +0200

Lupp gravatar image

So I've seen in forums you have to format cells to change decimal symbol. So the default is . and i tried to make it , . Pressed OK of course, tried to switch system decimal symbol and the error is still there even after saving, restarting libre office etc. What do I do wrong?

image description

edit retag flag offensive close merge delete

Comments

Answer depends heavily on OS. Which is yours? What's your locale? Also LO version may be useful.

ajlittoz gravatar imageajlittoz ( 2018-03-13 13:55:47 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-03-13 14:07:10 +0200

You have selected an explicit language for your cell (Greek). That makes the decimal separator to be what is hardcoded in LO for that locale. You should either select another language that uses the separator you need (e.g., French), of use Default-XXX (which means that the locale settings would be defined by higher-level settings, possibly OS).

edit flag offensive delete link more

Comments

This seems to be still messed up by hard coded assumptions. Here we are hard coded to use "," as the decimal separator, but nobody here uses ",". We use "." and "," as a thousands separator. This means I have three choices, convince libreoffice to allow changing he decimal separator, change to a different language, or convince everyone in South Africa to behave according to Libreoffice assumptions. Workarounds and dirty hacks are no fun.

Derek Keats gravatar imageDerek Keats ( 2019-06-29 17:04:03 +0200 )edit

If you believe that LibreOffice settings don't match a given country's actual proper values, please file a bug report, since that would be a bug. Thanks.

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-29 17:32:00 +0200 )edit
0

answered 2018-03-13 19:24:21 +0200

Gilward Kukel gravatar image

In "Tools - Options - Language Settings - Languages" set Locale setting to Greek. Then you will have to correct the formula, I think.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-03-13 13:18:41 +0200

Seen: 228 times

Last updated: Mar 13 '18